1

I'm struggling with the fractional scaling feature in gnome.

My current setup: Display1: 2736x1824 (on a surface pro 6) Display2: 1920x1080 Display3: 1920x1080

I've configured the scale for Display1 to 200%. But the current solution is disappointing. I've tried following scenarios:

Display1 scaled to 200%, Display2/3 to 100%, primary display = Display3: Windows are correctly display on Display2/3, Display1 doesn't scale anything except gnome-own applications. The surface screen looks like this

Display1 scaled to 200%, Display2/3 to 100%, primary display = Display1: All looks good on the surface now, all applications are scaled correctly. But all windows on display2/3 are scaled double, except gnome own application.

The surface screen looks like this Display3 looks like this

Display1 scaled to 200%, Display2&3 not connected: All is working fine!

I've already deleted the ~/.config/monitors.xml to give it try. And the surface was rebooted many times.

Any ideas how to solve the issue?

A friend of mine has the same setup and it works for him. We didn't find any difference in our setup.

I'm completely lost for now, any help would be great!

  • Fractional scaling is still experimental. If you have an issue you can report the bug on the GNOME gitlab page: gitlab.gnome.org/GNOME/gnome-shell/issues – Jerare Nov 28 '19 at 19:57
  • thx, I've opened an issue... nevertheless the confusing thing is that is works on my colleague's surface. same device, same os, ... – lama1234 Nov 28 '19 at 20:27
0

You will need to be using Wayland to use the experimental fractional scaling feature. This admittedly caught me as I've recently setup a second user account and went through enabling the experimental fractional scaling, but didn't see it come into effect.

https://www.omgubuntu.co.uk/2019/06/enable-fractional-scaling-ubuntu-19-04 describes how to setup fractional scaling.

The default login is not Wayland so on logging in, click the cog icon next to the Signup button and choose the Ubuntu on Wayland option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.