0

I was trying to get league of legends running on my ubuntu. Therefor I was trying to install vulkan drivers for my AMD HD7750 graphics card, which - according to wikipedia - is supported by the vulkan drivers. I was doing some more things to the settings according to some guides ok this topic which unfotunately I cant remember exactly. Now when booting the computer I just see my mainboards manufacturer with BIOS option, then I see for a short time this ubuntu-purple (or whatever color that is) background and then just a blackscreen with a flickering every now and then.
I tried going to recovery mode and deleting the vulkan drivers from root shell by executing

apt-get remove —auto-remove mesa-vulkan-drivers

But I’m atill facing the same issues. Any ideas on how to fix this or should I just format and reinstall ubuntu? (Formatting is not a huge issue since I dont have any important data on that computer)

0
  1. Start up the machine.
  2. Hold Shift to bring up GRUB.
  3. Pick a recovery option. (Alternatively, sometimes you can press CTRL + ALT + F3 and just go into a terminal).
  4. Reverse what you have done.
  5. Try the Oibaf drivers.

=== Basic usage ===

See "Adding this PPA to your system" later on, or just do:

sudo add-apt-repository ppa:oibaf/graphics-drivers

and update your Ubuntu with the package here.

sudo apt install mesa-vulkan-drivers

0

Try reinstalling the ubuntu-desktop (a.k.a GNOME).

  1. In order to run the above command press CTRL + ALT + 1. You can replace the 1 with any number from 1-6. Those are different sessions on your computer, CTRL+ALT+7 is the desktop session.

  2. login and run

     sudo apt install ubuntu-desktop
    

If you are using another desktop you might try to install that as well.

I have gotten myself to a similar situation trying to uninstall vulkan, since my GPU doesn't support it anyway.

!!! Do not run the below !!! I tried removing the vulkan drivers with:

    sudo apt autoremove libvulkan1 libvulkan1:i386

and this crashed my computer. After restarting, the desktop wouldn't start. I could log in, but not see the desktop, I did check the apt archives inside /var/log/apt/history.log, it turned out that apt decided to go berzerk and uninstall a ton of things. On top of that vulkan itself wasn't uninstalled. If I run the above, saying no of course, there is a huge list of things to uninstall along vulkan.

If you don't have anything fancy, formatting is always an option as you said. Installing gnome again, fixed it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.