1

I'm doing automated testing with Sikuli and it's important that the stuff being tested is visible on the screen. Lately, the apps/windows keep opening in the background, behind whatever is currently in focus, with the notification "[application] is ready". How do I tell Ubuntu to stop doing this?

  • This can happen when the window in front is set to "Always on Top". Right click on title bar and if set then uncheck the option. – WinEunuuchs2Unix Nov 27 '19 at 11:30
  • It's not "Always on Top". It's normally opened Eclipse window. It's doing it randomly, sometimes it opens in focus, sometimes in the background. – Tannalein Nov 27 '19 at 11:32
  • Hmmm... beats me. What I would do is use Alt+Tab to quickly bring into focus until someone comes up with a better solution. – WinEunuuchs2Unix Nov 27 '19 at 11:36
4

Gnome Shell, which is used by Ubuntu, has the feature that launched applications are opened in the background. While this may be desirable in some workflows, many users will consider this an annoyance. A gnome Shell extension, appropriately named "No Annoyance", changes this behavior, and makes sure a launched application is immediately raised.

Install the extension with the command sudo apt install gnome-shell-extension-no-annoyance, or using Synaptic Manager (not installed by default) or even using "Software". To enable the extension after installation, you can use "Gnome Tweaks" (not installed by default).

  • Thank you, this is a life saver. Testing it to see how well it works. – Tannalein Nov 28 '19 at 15:13
  • This is interesting. – WinEunuuchs2Unix Nov 28 '19 at 20:47
  • This work for Skype on Ubuntu 19.04 but not work on Ubuntu 19.10. On every skype message i see "windows is ready". How do i fix it? – tagplus5 Dec 17 '19 at 12:15
  • It is not a feature. It is a mistake in the design. If someone need to write a "no-annoyance" program that something is very wrong with the original system... And yes' it seems much worse in 19.10. – user1656671 Jan 1 at 10:35
0

There is an option in dconf-editor.

org / gnome / desktop / wm / preferences / auto-raise

enter image description here

It is possible that activating this option helps. It is hard for me to tell as I tried several things and I am not sure if it works consistently.

Another hack I am trying is to set org / gnome / desktop / wm / preferences / auto-raise-delay to 2000.

I would appreciate comments about the reflectivity of this setting.

enter image description here

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – guntbert Dec 16 '19 at 22:43
  • Unfortunately the behavior after application of this change is not clear. It claims to solve the situation yet it seems to do so only sometimes. I would actually appriciate a further clarification.. – user1656671 Dec 17 '19 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.