When I use gnome network manager it indicates that wireless is disabled by hardware switch while it is not. Even in windows I can not turn on my wireless!

  • How, and in which OS, did you enable Airplane mode? Apr 5 '12 at 13:35
  • in Ubuntu 12.04
    – Ameno
    Apr 5 '12 at 13:38
  • Ok, that answers part of my question, now how did you enable airplane mode? Was it in a menu? If so, was it labelled 'Enable Airplane Mode'? I don't see any such option on my Ubuntu machine. Apr 5 '12 at 13:42
  • 1
    yep, in network there is Airplane mode in right corner and I turn that on, but when I turn it off and close that windows and reopen network its on!!!
    – Ameno
    Apr 5 '12 at 13:52
  • 3
    Possibly you should file a bug - 12.04 is still in development!
    – Jakob
    Apr 5 '12 at 14:39

I just tried this:

shell> sudo rfkill list all

The output was something like this:

0: sony-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Then I have run this command:

shell> sudo rfkill unblock wifi

and all is fine now :) Have fun :) I hope it will help you :)


To explicitly check your wireless is turn off by hardware switch or not, you can use

sudo rfkill list all

Then you can use this command to unblock every blocked component there:

sudo rfkill unblock all

I think this is just a new manifestation of an old problem that affects Vaio laptops. I have one too, ran into the same problem with 12.04 (beta 2), and had success using the same solution I used with Ubuntu 11.*:

sudo rmmod acer_wmi
sudo rfkill unblock wifi

Let me know if that works for you. I think Ubuntu gets confused by having both "sony-wifi" and "acer-wireless" (which you can see in the previous answers "sudo rfkill list all"), and the rmmod will clear the "acer-wireless" option.

A more permanent version of this solution, suggested on this thread http://ubuntuforums.org/archive/index.php/t-1859633.html, is to just blacklist it by adding

blacklist acer_wmi



and then restarting your system.


This thread came up tops in search but was not marked SOLVED so I'll post what worked for me.

Most driver and configuration bugs have been worked out, hence methods to remove or override stubborn hardware locks don't work and lead only to frustration.

The first step should be to locate the wifi/wlan switch and toggle it. It may be a function key, slider switch or other. If unsure of its location, head to the mfr's website and search the manual.

Those who, like me, leave WIFI on all the time are most susceptible to this trouble. We don't use the switch so we're not mindful of it.

After wasting hours searching and trying many suggestions like others here, I finally reviewed the documentation and found the tiny switch that had been accidentally toggled. Toggled it back and everything started working again.


Check your BIOS settings. In my laptop's BIOS, there is an option of shutting down Wireless, Bluetooth and other networking interfaces.

The other problem might be that there is a physical problem with your Wireless hardware

The other case might be that your hardware is blacklisted. Check if the module is blacklisted in

cat /etc/modprobe.d/blacklist.conf

if it is not present in this, check other blacklist files in /etc/modprobe.d/ folder

Additionally please check that in Network in System Settings the interfaces listed on the left have ON toggled for Wired and Wireless. I am using Wired, so only one is showing. In your case both should show

enter image description here

  • my laptop is vaio and there is no such settings in Bios!
    – Ameno
    Apr 5 '12 at 13:38
  • Did you check each and every settings? Apr 5 '12 at 13:39
  • yep, eveeeeery setting, problem is some of vaio's bios is awful with no setting in Bios page!
    – Ameno
    Apr 5 '12 at 13:40
  • my lan setting work correctly right now but wireless is off and I cant turn it on!
    – Ameno
    Apr 5 '12 at 13:41
  • 1
    I cant turn on wireless, each time I open this window airplane mode is on and if I turn it off it cause no effect! and I cant turn my wireless on because it said wireless is disconnected by hardware switch!! which is not!
    – Ameno
    Apr 5 '12 at 13:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.