1

I am suffering from extreme brightness on Ubuntu 18.04. I have recently downloaded this version, however my brightness keys are not working and I cannot change the brightness levels. My PC is Lenovo Yoga S740.

xrandr is not working I have tried it before. It gives me this error:

xrandr: Failed to get size of gamma for output default

Also this does not give any output:

ls /sys/class/backlight/

I have also tried to change the grub file but nothing is working for me. (I also tried to change it as acpi_backlight=video etc.)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Finally, xbacklight doesn't work too. How can I solve this issue?

8
  • Did you sudo update-grub every time after editing /etc/default/grub? – havon Nov 27 '19 at 11:08
  • What parameters have you tried except acpi_backlight=video and acpi_backlight=vendor? And please provide the output of uname -r. – havon Nov 27 '19 at 11:25
  • Yeah i tried sudo update-grub and reboot my computer but it did not work. – Elcin Duman Nov 27 '19 at 17:52
  • uname -r gave me this: 5.0.0-36-generic – Elcin Duman Nov 27 '19 at 17:59
  • Try also ‘acpi_backlight=native’ and ’acpi_backlight=none’ parameters. Check if any of the parameters you've tried changes the output of ’ls /sys/class/backlight/’ – havon Nov 27 '19 at 20:57
0

It seems to be a kernel bug. Try some other kernel versions, especially 4.19.86 and 5.3.13 without any parameters and with the parameters you've already used. If none of them works try the latest unstable kernel 5.4. Always check ls -l /sys/class/backlight since if you have some subdirectories in /sys/class/backlight it means you potentially can set the screen brightness.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.