0

I used this command 'sudo passwd -d user' which I thought would just delete my regular users password but now I can't even log in as root. I've tried sudo -i and it doesn't work and I can't use root privileges. Hope someone can help. Thanks

  • 1
    Have you tried just pressing Enter when sudo prompts for your password? The command should have set your password to empty. – zwets Nov 26 '19 at 5:53
  • No, the terminal responds as if I'm entering the wrong password when I press enter. – podjv Nov 26 '19 at 15:02
1

I did find a solution to my problem. I booted into the Grub menu by continually pressing 'shift' when booting up then went to advanced options and loged in to root which didn't require a password. Then I simply changed my password for both sudo and my user by typing 'passwd' for sudo then 'passwd user' for my user and not I have system back to normal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.