0

Ubuntu Gnome 18.04.

None of my audio devices (S/PDIF interfaces, HDMI, or USB Kingston HyperX headphones) appear in the sound panel, of my fresh install.

I've used MANY distros, including this Ubuntu 18.04, with the same headphones on the same machine, over the past few years, and have never had this issue.

I found this article and it said to do the following:

sudo apt-get remove --purge alsa-base

sudo apt-get remove --purge pulseaudio

sudo apt-get install alsa-base

sudo apt-get install pulseaudio

sudo alsa force-reload

Then reboot

THIS WORKS, but after rebooting it's missing all of the devices again. I tried everything else in that article as well.

I also tried removing the folder:

~.config/Pulse

and rebooting to have the system rebuild it, but it doesn't work either. The contents of that folder are as follows:

  • 52d08a3291ab4c5a90ad1f14948aeb7a-card-database.tdb

  • 52d08a3291ab4c5a90ad1f14948aeb7a-default-sink

  • 52d08a3291ab4c5a90ad1f14948aeb7a-default-source

  • 52d08a3291ab4c5a90ad1f14948aeb7a-device-volumes.tdb

  • 52d08a3291ab4c5a90ad1f14948aeb7a-runtime

  • 52d08a3291ab4c5a90ad1f14948aeb7a-stream-volumes.tdb

  • cookie

Here is my lspci -k

output: https://hastebin.com/raw/supidakiro (pastebin is down for me right now)

Not sure what other info to provide. Let me know and I'll try to give more info.


EDIT:

Those commands from the article no longer work, even temporarily anymore. I found this article and did this command:

pulseaudio --start --log-target=syslog

and it immediately fixes it. So how can I make this happen automatically at boot? I'd still like to know how this was broken too, since I've never had this issue before....

0

adding a new startup command to "startup applications" with the following on the command line:

pulseaudio --start --log-target=syslog

rebooted and now pulseaudio starts as it should.

I'm still curious as to why this broke in the first place. This is a fresh install...

EDIT: from this post I did the following:

cp -p /etc/pulse/client.conf ~/.config/pulse/client.conf

and now my audio works even after rebooting.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.