1

I am no longer able to access external drives on my computer (running Ubuntu 18.04 LTS). It was working fine a few weeks ago, so I'm not sure what changed.

I get this error message when trying to open the drive in Nautilus, for both USB drives and my extra hard drive:

Unable to access "8.1 GB Volume"
Not authorized to perform action

When I run Nautilus as root, it doesn't even show the drives. I was able to run sudo gnome-disks and interact with the drives that way. If I just run gnome-disks, then I don't have permissions and get the same error message.

I don't have this issue on another Ubuntu 18.04 LTS machine with the same USB drive. Nautilus without root works fine. So I don't think the issue is with the drives but rather is with the computer.

1
  • Please show us, findmnt | grep media and getfactl /media/$USER – nobody Nov 25 '19 at 18:17
5

I finally figured it out. My user account was part of the chrome-remote-desktop group. Once I removed it from that group and restarted my computer, auto-mounting and accessing the drives works as expected.

I had added my user to the chrome-remote-desktop following this post: https://superuser.com/a/850359/588342. After doing so, chrome-remote-desktop auto-runs on startup. Instead of that, I just added a command to run it in "Startup Applications Preferences": /opt/google/chrome-remote-desktop/chrome-remote-desktop --start

3
  • Hello, what is your solution? Keep using remote-desktop and auto mount at the same time. I mean once you add your user back to that group chrome-remote-desktop auto mount is not working, but when you remove the user from that group, remote-desktop is not working. – sflee Jan 12 '20 at 12:49
  • 1
    I removed my user from the group chrome-remote-desktop and added chrome-remote-desktop to the startup applications via the GUI. Both auto mount and chrome-remote-desktop are working for me now. – catanasian Jan 14 '20 at 1:21
  • Thank you very much. – sflee Jan 14 '20 at 2:18
1

Use command:

sudo chown yourusername:yourusername /media/yourusername/path_to_mounted_volume

In nautilus user mode the volumes are mounted in /media/yourusername/

Replace yourusername with your user name and path_to_mounted_volume with path from command:

ls -l /media/yourusername/
12
  • ls -l /media/yourusername/ returns total 0. There's no path_to_mounted_volume. – catanasian Nov 25 '19 at 17:32
  • First mount the volume using nautilus. The output should be somehow: drwxr-xr-x 11 root root 4096 júl 7 18:06 disk2 – kukulo Nov 25 '19 at 17:35
  • The d in drwxr-xr-x stands for directory. Of course your name will be different. – kukulo Nov 25 '19 at 17:36
  • Change yourusername to your user name. – kukulo Nov 25 '19 at 17:37
  • Trying to mount using Nautilus gives me the same error: Unable to access location Not authorized to perform operation – catanasian Nov 25 '19 at 17:51
0

I have tried it but still can't work. The workaround is keep username in chrome-remote-desktop. Remove chrome-remote-desktop service from systemctl.

sudo systemctl disable chrome-remote-desktop

Then add command /opt/google/chrome-remote-desktop/chrome-remote-desktop --start to "Startup Applications Preferences" via the GUI.

3
  • # systemctl disable chrome-remote-desktopchrome-remote-desktop.service is not a native service, redirecting to systemd-sysv-install. Executing: /lib/systemd/systemd-sysv-install disable chrome-remote-desktop – James Bowery Mar 1 '20 at 19:27
  • Didn't work after systemctl disable and run on startup. Still get "Not authorized...." even after reboot. – James Bowery Mar 1 '20 at 19:45
  • Worked after # gpasswd -d myusername chrome-remote-desktop so I'm not sure why you said "keep username in chrome-remote-desktop" when a prior answer said to delete it from chrome-remote-desktop and gave the other commands you gave. ie: The prior answer gave the correct solution at least for me but apparently did more than you needed. – James Bowery Mar 1 '20 at 19:55
0

Today I had the same issue with my external 500gb hdd, I did next, it helped me:

sudo apt remove chrome-remote-desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.