0

I must use "scons" in version 3.0.x but in Ubuntu eoan scons is at version 3.1.x [0]. I tried to edit /etc/apt/sources.list and added

deb http://de.archive.ubuntu.com/ubuntu bionic main

After sudo apt update sudo apt list scons still only shows scons/eoan,eoan 3.1.1.-3 all

How can I install scons 3.0.x on Ubuntu Eoan?

[0] https://packages.ubuntu.com/search?keywords=scons

7
  • 2
    Did you try installing scons with the version name as well? sudo apt install scons=3.0.1-1 After you install that version it is recommended that you put a hold on the app so it doesn't upgrade sudo apt hold scons then remove or comment out the older bionic source.
    – Terrance
    Nov 25 '19 at 14:22
  • 1
    Ah, you setup the wrong PPA. It is in the universe and not main. After setting it up you should be able to run apt-cache madison scons and it should show you all the versions available.
    – Terrance
    Nov 25 '19 at 14:29
  • 1
    Here's the best info I can give you for that: askubuntu.com/a/58365/231142
    – Terrance
    Nov 25 '19 at 14:43
  • 1
    Thank you. By the way sudo apt hold scons doesn't work but sudo apt-mark hold scons does
    – phip1611
    Nov 25 '19 at 14:46
  • 1
    Oops, my bad! That is what I get for writing a response this early in the morning! =) Glad it is working for you!
    – Terrance
    Nov 25 '19 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.