4

My Lenovo Y540 with NVIDIA RTX 2060 doesn't wake up properly after suspension. The computer seems to work as I can turn the volume up or down (and hear the a characteristic sound) but the screen is blank. I know that this issue was raised couple of times on this site, but neither of excisting solution, like this or updating kernel (I have 5.0.0-36-generic already) seems to work for me.

If there is any console output that could enhance the quality of this question, I'll be happy to update.

1
  • Have you tried this yet? – Fabby Nov 28 '19 at 10:50
3
+50

I had this driver problem 1 year ago.

As per https://www.geforce.com/drivers. Version: 440.36 is the recent stable and recommended driver avalible for NVIDIA RTX 2060.

Recent packages are avalible in graphics-drivers/ppa

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt install nvidia-driver-440

If problem continues, then try switch to nvidia-dkms-440

sudo apt install dkms nvidia-dkms-440 

For me nvidia-dkms-440 working well for 940mx. This should solve your problem.

1
  • 1
    This worked, but with minor tweak: I had to input sudo apt install nvidia-driver-440 instead of sudo apt install nvidia-440 - it appears that the syntax has changed. – jakes Nov 30 '19 at 18:48
0

you must install nvidia driver and reboot your laptop. I had same problem today and fixed it by installing nvidia driver

0

As mentioned, try first installing drivers in Software & Updates app. And select "Using NVIDIA drive rmetapackage from nvidia-driver***" and pick the highest number.

If the issue persists, then you should update to newer version of the Nvidia drivers perhaps through PPA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.