0

I have a very old Dell Vostro 1015 laptop, and just installed Ubuntu 18.04.3 LTS on it. The problem is that I cannot use wifi, in the wifi settings it says "no wifi adapter found" (the bluetooth has the same issue). The internet works with ethernet cable though.

I did extensive research here in the forum but none of the solution options worked, I suppose each case is specific:) Therefore I run the wireless-info script command, please see the result in the linked Ubuntu Pastebin sitewireless-info

What I've done? I've tried to update the system, nothing; to restart the network manager, nothing; and to install the most up-to-date driver for my wifi adapter according to this r8168/r8169 RealTek driver module troubles nothing. Please, help me! thanks a lot!!!!

  • 1
    r8168/r8169 is a wired adapter and has nothing to do with wifi. – Pilot6 Nov 23 '19 at 21:06
  • 1
    Your wireless adapter is Broadcom Inc. and subsidiaries BCM4312 802.11b/g LP-PHY [14e4:4315] – Pilot6 Nov 23 '19 at 21:08
  • yes, thank you! – path Nov 23 '19 at 21:46
0

r8169 is a wired Ethernet adapter and is not related to Wi-Fi.

You can install firmware for your Broadcom wireless adapter by

sudo apt install firmware-b43-installer

Reboot and Wi-Fi should work.

I suggest removing r8168-dkms driver. It may cause problems on kernel upates and it is not needed at all.

  • Thank you, Pilot6, it is working now, I did exactly what you have said. Thank you! – path Nov 23 '19 at 21:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.