1

I have a similar laptop to

Ubuntu 19.10 installer doesn't start on my Dell Inspiron 5491

But I am opening another question as the problem I face is different. The laptop is quite new and did not find any experience with the Ubuntu installation.

After switching from RAID to AHCI, disabling a secure boot, updating the BIOS, and play around with the BIOS option, I am trying to install Ubuntu 18.04.03.

I am not actually installing it but just using "Try Ubuntu". I pass to the bootloader the options nomodeset intel_idle.max_state=1 without which the installation stops very early. I've also played around with ipv6.disable.

Everything stops while turning on services(see attached figure). In particular acpid.service is the last thing I see, then the system freezes.

I suspect it is related to ACPI setup but don't have any clue on how to fix it. Any suggestion is much appreciated.

Freezing while acpid.service

4
  • Did you validate your ISO after download (to ensure it was perfect)? tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0 and then your write to media (to ensure it was flawless)? help.ubuntu.com/community/Installation/CDIntegrityCheck It's where I'd start – guiverc Nov 23 '19 at 10:22
  • Or if possible just try with netboot media of ubuntu from cdimage.ubuntu.com/netboot – jkp Nov 23 '19 at 10:32
  • Yes I verified the integrity of the ISO image with the "Check disk" when I boat. I am boating from USB stick. I ve used Rufus 3.8 from Win10 to write the Ubuntu ISO into the USB stick, using MBR as partition scheme (suggested in other posts). I also tried GPT but no difference. The Laptop BIOS supports only UEFI. – Andrea Nov 23 '19 at 11:05
  • I have seen where Rufus with MBR only creates UEFI/CSM which is BIOS. You want gpt/UEFI. CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode, only available with secure boot off. – oldfred Nov 23 '19 at 23:36
2

I have the same computer and for me it works with "noapic" on Ubuntu 18.04 and 19.10, and with "nolapic" on other distro.

Once 19.10 installed, it works great except the touch screen which is not reconized and the sleeping mode (suspend). I spent hours on it with no sucess for the moment. if you found any tips let me know.

1
  • Thanks, with "noapic" I can go ahead and install Ubuntu19 (nolapic causes WIFI not to work). Touch screen doesn't work, and is not even listed by "lsusb" (assuming it is connected through usb). Also, finger print doesn't work either, drivers seem to be missing, but it is recognized by "lsusb" (27c6:538c Goodix FingerPrint). – Andrea Dec 16 '19 at 13:23
1

Installed Ubuntu 19.10 with dual boot windows 10 on the same model -- Dell inspiron 5491, 2 in 1 touchscreen with 512Gb single SSD, with i7 intel, (not amd-ry-zen).

Main challenges

  • Live USB trial booting process would freeze. BIOS update took care of that.
  • Once live version booted: Linux installers (Ubuntu/Fedora) were unable to "see" the SSD. Switching from RAID to AHCI fixes this. Be careful, put windows in Safe Mode first! Do a dry run of booting windows in safe-mode, then back to normal mode to gain familiarity.

Steps

  • Update Window 10 (and optionally, fresh start)
  • Update BIOS from dell support site. This also updated some drivers.
  • Use msconfig in windows 10 to set windows to boot in Safe Mode (minimal version). Some people use DOS commands, I simply used msconfig GUI.
  • While windows 10 is set to safe mode, change the BIOS SATA settings (using F2 to get into BIOS while powering up) from RAID to AHCI.
  • After switching to AHCI, start windows 10 (which should already be in safe mode).
  • Once windows boots up, go back to msconfig and uncheck and turn off Safe Mode.
  • Reboot windows normally (it will now be in working in AHCI SATA mode).
  • Reboot the machine and proceed with linux installation using live USB and grub 2.

Misc

  • Updating BIOS/drivers (from Dell's support site) was key to make live USB trial work without any specific grub 2 options.
  • I used windows 10 to shrink the C drive and create free space for the linux installation. Some folks do this during the linux install process.
  • When trying out linux (Fedora/Ubuntu) from live usb, sometimes the wi-fi adapter was not detected. I found that just entering e to enter grub 2's boot options setting (without actually changing anything) and then using Ctrl-x or F10 to proceed resulted in the wi-fi adapter being recognized.
  • On ubuntu, Google Chrome handles touchscreen (scrolling and multi-touch) better than the included Firefox.

Stuff I read on the web (and tried earlier, but was not needed)

  • Did not switch off "secure boot". In fact, I set up a password for secure boot during the Ubuntu installation (for 3rd party software/drivers).
  • No options passed to grub 2, none at all. Tried those earlier, such as nomodeset or noapic, but then wi-fi or touchscreen wouldn't work on even on the live USB trial version).
2
  • Thanks a lot Pete. Just a follow-up question: did you specifically do anything for the touch screen recognition? In my case no way to make it work... in Ubuntu 19. – Andrea Jan 29 '20 at 21:11
  • Nope @Andrea, I did not have to do anything for touch screen. Just the BIOS update + switching from RAID to AHCI. No options or arguments passed to grub 2. I think I had touchscreen issues with Ubuntu 18.04. Didn't bother with that once 19.10 and Fedora worked out. – Pete Carkeek Jan 31 '20 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.