I recently updated my graphic card to Geforce GTX 1650, previously I had no graphics card, and was using Ryzen 2200g with 8gb ram with one monitor for my daily activities.

Prior to upgrading my card, I was dual booting windows 10 and Ubuntu 19.10 and everything was running very smoothly.

After upgrading one graphic card (GTX 1650) and one monitor, i.e running dual monitor now was added to my setup.

When I booted for the first time, as usual, I selected Ubuntu as my boot option but it got stuck in "pink" (the solid pinkish Ubuntu colour) blank screen then again I rebooted system but this time it allowed me to sign in, I entered my details but it asked me to sign in again, and process repeated multiple times and I just dropped the idea and logged in, in windows 10, which booted successfully, in fact currently using windows 10 as my OS.

I thought that maybe since I changed the hardware I need to install fresh copy of the OS, so I deleted Ubuntu from the hard disk completely with the proper removal process and was able to reboot to Windows 10 successfully.

Now I tried to install Ubuntu 19.10 again from the same USB drive from which I previously installed Ubuntu (2-3 weeks back), but this time I was not able to install, here is exactly what happens when I try to install:

  1. I choose the "boot from USB" option after pressing the Del key.

  2. I select my USB drive.

  3. I get black screen and it spams

    AMD-Vi: Completion-Wait loop timed out

    many times with some other data.

  4. Then, after all that, it ends with:

    [ end Kernel Panic - not syncing: Fatal exception in interrupt ]

Please help me! I want to dual boot Windows 10 and Ubuntu, can't figure out what to do, tried googling and various solutions given online.


Not sure how to fix your current problem, but I have a similar problem to the original login issue that you had but only with Auto Login enabled. If you find yourself back in that situation, this post may help

After upgrade to 19.10, still get login screen after enabling Auto Login, but can't log in


I figured out the way to do it.

You need to update your BIOS and then reinstall Ubuntu again and it will work

So Simple!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.