0

The computer is a DELL Laptop, model: Latitude 3590. BIOS date and version: Dell Inc. 1.4.0 1/3/2018.

I made a new partition layout for a dual boot.

I installed Windows 10 Pro version 10.0.15063.

Then I installed Xubuntu 18.04.

As a result I obtained a dual boot that worked great, for more than 2 months.

One day the computer did not showed the GRUB any more, and initiated Windows 10.

I have restored the GRUB, and I have tested that both systems can boot. However after 24 hours the GRUB is missing again.

I have restored the GRUB 2 times, with same result every time: GRUB missing again after 24 hours. 

To restore the GRUB I utilized a live Xubuntu 18.04 in a pendrive, and I followed this steps:

In the live Xubuntu:  

sudo mount / dev/sda1 /mnt

sudo mount / dev /mnt/ dev sudo mount /proc /mnt/proc

sudo mount /dev/sda2 /mnt/boot/efi sudo chroot /mnt

grub-install --recheck / dev/sda

In the installed Xubuntu:

sudo update-grub2

This is the BIOS configuration am using: -Sata Operation: RAID ON

-Secure Boot Enable: Disable

-Enable Legacy Options ROM's: true

-Enable Attempt Legacy Boot: false

-Boot List Options: UEFI

I have a dual boot of both systems in a PEAK laptop. And never has failed since its installation. So, I think this issue is related with the BIOS or its configuration.

This are my questions: 1) What am I doing wrong ? 2) Does DELL-Latitude 3590 need a special BIOS settings for the dual boot that I need ?

Any suggestion is welcome ! Thank you very much in advance !

  • 1
    Generally with Dell, you install AHCI drivers into Windows and change UEFI to AHCI. And make sure UEFI is latest version. If SSD make sure it has latest firmware. Windows updates often make Windows first in boot order, you just need to reset to make grub first again. Both systems are UEFI? – oldfred Nov 22 '19 at 21:18
0

The solution I have found is to use SHIMx64 in the boot selection setting, in the BIOS.

This is described in detail in this DELL article: XPS 13 9343: How to Install Ubuntu Developer Edition 14.04 on a Dell PC Configured for the Unified Extensible Firmware Interface (UEFI) BIOS

There is also another good explanation of why this works in this question: What is the difference between grubx64 and shimx64?

I hope this can help others.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.