0

I don't have enough points to comment here

How can I install on a non-PAE CPU? (error "Kernel requires features not present on the CPU: PAE")

so am asking a new question.

I recently acquired an IBM T41 ThinkPad (Pentium M) that came installed with Ubuntu 12.04. I installed Windows XP over that, and now want to go back to Linux---specifically Lubuntu 18.04 LTS 32 bit.

When I type in "forcepae --- forcepae" at the outset it seems like it will work. The installation begins but soon after setting up the keyboard and scanning <...cdrom...> it freezes. I had hoped the older machine was just taking a long time to do something but after about 10 minutes I still have a blue screen. I tried installing several times, using both DVD and USB (Rufus). Same problem.

Any tips to help a non-expert?

  • I have and use a T42 that runs Lubuntu 18.04 LTS, and yes I did need to use forcepae --forcepae on much earlier release of Lubuntu, the linux kernel in 18.04 can cope with the pentium M's bugs without those options now. I'd question first if you validated ISO after download to ensure perfect tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0 and then validated write to install media help.ubuntu.com/community/Installation/CDIntegrityCheck. I used one of my T42's to test Lubuntu up to 19.04 (when x86 images were dropped Dec-2018). What size RAM do you have? – guiverc Nov 22 at 20:58
  • I only have 2 GB ram but I did get it to work beautifully---am using it right now. My solution is one of two things: (A) I did an OEM install and (B) also waited longer during that blue screen (I was called away from the T41 - my model - and when I came back, the installation had resumed). So I don't know if it was the extra waiting time or the OEM install that solved it. Is there a 19.04 32 bit image out there somewhere? I would like to try that if possible. – earthpages Nov 23 at 0:26
  • It'll most likely be the wait... My testing was on boxes with 1GB or more of RAM (my most used T42 has 1.5gb; my other 1gb - my RAM question was more if you had <768mb where 'live' + 'ubiquity' installer requires >700mb ram. I'll add a precaution to go to official web sites (google offers many for Lubuntu, with only 1 being related to Ubuntu/Lubuntu & it's not usually first) so it's best to search at ubuntu.com for flavors (ie. ubuntu.com/download/flavours); ie. official site is lubuntu.me – guiverc Nov 23 at 0:55
  • Yes when I believed only 12.04 was possible I did try a distro that had all sorts of customizations included. I was suspicious so ditched it and reset my bios to default (just in case). Then I learned about forcepae. My T41 is working great, esp with remote desktop (as viewer) software. Lubuntu 18.04 outperforms Windows XP in that area. – earthpages Nov 23 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.