1

Ubuntu 18.04 install (also seen on 16) is unable to detect integrated Intel graphics card (Intel Iris Plus). Using a Dell XPS 13 2-in-1 7390 the machine is unable to detect attached monitors, change resolutions, or adjust brightness.

There is a dual boot Windows 10 partition, which can access the integrated graphics card without issue and connects to attached monitors on boot. However, after deleting the W10 partition the behaviour is unchanged.

$ lsb_release -rd
Description: Ubuntu 18.04.3 LTS
Release: 18.04
% uname -o
4.15.0-70-generic
$ apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.99.917+git20171229-1
  Candidate: 2:2.99.917+git20171229-1
  Version table:
 *** 2:2.99.917+git20171229-1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
$ lspci -v
00:02.0 VGA compatible controller: Intel Corporation Device 8a52 (rev 07) (prog-if 00 [VGA controller])
 Subsystem: Dell Device 08b0
 Flags: bus master, fast devsel, latency 0, IRQ 255
 Memory at 603d000000 (64-bit, non-prefetchable) [size=16M]
 Memory at 4000000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 4000 [size=64]
 [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
 Capabilities: <access denied>

System details, graphics displayed ass llvmpipe

I have tried purging nux-tools to remove a leftover file that interfered with gnome as detailed in this bug.

Further, this fix for intel integrated graphics cards also produced no results.

  • Please edit your question and add output of lspci -k | grep -EA3 'VGA|3D|Display' terminal command. – Pilot6 Nov 22 '19 at 16:48
1

I suggest to upgrade the kernel to an officially supported HWE kernel.

You can do it by running

sudo apt install linux-generic-hwe-18.04

Reboot to apply.

|improve this answer|||||
  • It worked perfectly fine for me.. thanks a lot.... – Sandeep J Patel Mar 24 at 7:11
0

I have the same problem with the same graphics card in a Dell Inspiron 5593, I solved the problem of the brightness updating the kernel to the latest version.

You can easily update the Kernel with ukuu, it's totally safe, if you have problems with a newest Kernel, you just boot with an old Kernel and change the Kernel version again with ukuu.

If you find a solution to the llvmpipe problem, please write about it, I'm still looking for something.

|improve this answer|||||
  • There is no need to install a mainline kernel with non-free UKUU, if there is an officially supported upgrade path. – Pilot6 Nov 22 '19 at 16:51
  • I was trying to do that wiith "sudo apt install linux-generic-hwe-18.04", but the Kernel was not updating further than 4.15.0.70, so I tried ukuu. – Alan Gomez Nov 22 '19 at 19:16
  • Now it installs the 5.0. – Pilot6 Nov 22 '19 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.