Currently I'm running Linux-3.0 and I want to update it to Linux-3.3.1 the latest stable kernel release as mentioned at http://www.kernel.org. Can I update to 3.3.1 in Ubuntu without any risk of crashes? I'm updating my kernel regularly as provided by the Update Manager..Currently I have Linux- I update?


The latest kernel version any user is supposed to use in Ubuntu is updated automatically via the Update Manager, so no action is normally required by user regarding kernel upgrades. What the question author is referring to is mainline kernel, see: Should I upgrade to the "mainline" kernels?


17 Answers 17


The simplest set of instructions I always used for kernel upgrade / downgrade are by ubuntuforums.org user by the name of lykwydchykyn (url modified by me for this post):

  1. Go here: http://kernel.ubuntu.com/~kernel-ppa/mainline/
  2. Download 3 (maybe 4) debs to a folder somewhere:

    linux-image-extra-VERSION-NUMBER_amd64.deb   # if available
  3. Install the debs with whatever package manager front-end you use (is gdebi still around?), or use these commands:

    cd /path/to/folder/where/you/put/the/debs
    sudo dpkg -i *.deb


  • 5
    for example here you find two versions for each architecture: lowlatency and generic, which to take? kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty
    – rubo77
    Aug 7, 2014 at 2:42
  • No luck. I was coming from the 64-bit Utopic lowlatency kernel (3.16.0-31) in the standard repo. I upgraded to v3.16.7-ckt8 ( linux-image-3.16.7-031607-lowlatency_3.16.7-031607.201503111033_amd64.deb) which is running but still no trackpad. This is for an Acer C710. Mar 22, 2015 at 23:58
  • 1
    For completeness, in addition to @Bucic's steps -- (4) accept the new grub boot loader (1st option). This is probably what most people need. In case you would like to see exactly what changes, do a comparison to check, but it'll probably just rewrite your Grub conf file with the new kernel info you want. (5) reboot. Additionally, this is the much safer route, which will also upgrade your Linux version: sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot. In either scenario, after rebooting, run echo $(uname -r) to confirm that you successfully booted into your new kernel. Jun 1, 2016 at 4:18
  • 1
    @rubo77 on lowlatency vs generic: askubuntu.com/questions/126664/…
    – Noremac
    Dec 12, 2016 at 17:10
  • 1
    Be aware that linux-image-extra-... meanwhile is called linux-modules-extra-....
    – Wolfson
    May 5, 2021 at 16:47

You could always do the following:

apt-cache search linux-image

Pick the one you want and then do:

sudo apt-get install linux-image-your_version_choice linux-headers-your_version_choice linux-modules-extra-your_version_choice
  • 4
    That would not give a mainline kernel; rather, it would give an Ubuntu build (of the specified version number). Jan 5, 2013 at 9:17
  • 17
    Probably better than going with a mainline one though, since it's been massaged for the target OS. Oct 2, 2013 at 3:43
  • Worked like a charm in Debian 8. Thank you!
    – GTodorov
    Feb 2, 2015 at 18:54
  • 11
    don't forget to install kernel headers too: sudo apt-get install linux-headers-[version]-generic. [version] should be the same as kernel version
    – mauek unak
    Feb 23, 2016 at 20:49
  • 1
    This entry should be changed so it also instructs the user to install the linux-image-extra package because without it some things might not work - like an USB keyboard you use for entering the password to decrypt your disk.
    – wojci
    Jan 1, 2017 at 15:01

My answer is, YES you can. The stable release was 3.4, but in this tutorial i use 3.3.1.

Ubuntu (32-bit) Generic PAE:

Run the following commands:

mkdir kernel\ v3.3.1-precise && cd kernel\ v3.3.1-precise
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3.1-precise/linux-headers-3.3.1-030301-generic-pae_3.3.1-030301.201204021435_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3.1-precise/linux-headers-3.3.1-030301_3.3.1-030301.201204021435_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3.1-precise/linux-image-3.3.1-030301-generic-pae_3.3.1-030301.201204021435_i386.deb
sudo dpkg -i linux-*.deb 
sudo update-grub
sudo reboot now

Ubuntu (64-bit):

Run the following commands:

mkdir kernel\ v3.3.1-precise && cd kernel\ v3.3.1-precise
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3.1-precise/linux-headers-3.3.1-030301-generic_3.3.1-030301.201204021435_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3.1-precise/linux-headers-3.3.1-030301_3.3.1-030301.201204021435_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3.1-precise/linux-image-3.3.1-030301-generic_3.3.1-030301.201204021435_amd64.deb
sudo dpkg -i linux-*.deb 
sudo update-grub
sudo reboot now


  • i install the kernel 3.8.5-raring as you said on my Ubuntu 12.04. but now my OS is down and there is no cli or any grub menu. just thinking.
    – shgnInc
    Apr 2, 2013 at 16:05
  • Good but needs to be updated. I recommend finding the version and then google how to install it. Click the pages until you find something like this. For rc6 I found this yourownlinux.com/2016/03/… Mar 4, 2016 at 15:17

Contrary to some answers here Ubuntu releases the new kernel within a day or two of the main kernel team. I used to upgrade the hard way like some of the answers here suggest but I found this is an easier way.

Implications of manually installing Kernels

Manually installing kernels requires extra work.

There are reasons why you want to install the latest mainline kernel:

  • A bug in the last Ubuntu LTS kernel update and you can't downgrade
  • You have new hardware not supported in the current Ubuntu LTS kernel update stream or HWE updates
  • You want a security upgrade or new feature only available in the latest mainline kernel version.

As of January 15, 2018 the latest stable mainline kernel is 4.14.13. At the time of writing many are interested to install it for protection against Meltdown security hole. If you choose to manually install it you should know:

  • Older LTS kernels will not get updated until they are greater than the main menu first option titled Ubuntu.
  • Manually installed kernels are not removed with the usual sudo apt auto-remove command. You need to follow this: How do I remove old kernel versions to clean up the boot menu?
  • Monitor developments in the older kernels for when you want to get back on the regular LTS kernel update method. Then delete the manually installed mainline kernel as described in the previous bullet point link.
  • After manually removing the newest mainline kernel run sudo update-grub and then Ubuntu's latest LTS kernel will be the first option called Ubuntu on Grub's main menu.

Finding the latest kernel

Go to (kernel.ubuntu.com - Kernel PPA Mainline) and press the End key:

Mainline kernel 1

Now click on the link 4.9.8 (or a newer one if available when you read this) and the following appears:

mainline kernel 2

Note the links with the black airbrush marks. These are the three we will download for Ubuntu 16.04 64-Bit using Intel or AMD processors.

Installing using Terminal

Open a terminal session with Ctrl+Alt+T and use:

cd ~/Downloads # Change to your downloads directory
ll linux*.deb  # Check if any previous downloads still exist
rm linux*.deb  # Use this command if any previous downloads found

Now switch back to the download screen above and single-click on all three of the .deb kernel downloads. After downloads complete (you'll see status in your browser) switch back to terminal session and use:

sudo dpkg -i linux*.deb
rm linux*.deb
sudo reboot

Voila! - you are running the latest kernel when the first option in grub boot menu is selected. Your older kernel versions are still available under grub's Advanced Options menu.

After installing the newest kernel a dozen times you will ask the question "How do I remove older kernel versions?" and you will find those answers here in Ask Ubuntu.

  • You should answer this one saying "Don't complicate your life".
    – Fabby
    Jul 9, 2019 at 23:37
  • The layout and logging of the kernel page has changed. It would be great if you could refresh this answer's text and screen cap
    – 8bitjunkie
    Oct 25, 2020 at 11:53
  • @8bitjunkie I just check version 4.9 kernel and it appears the same. What kernel version were you looking at? Oct 25, 2020 at 15:52
  • Hi, @WinEunuuchs2Unix, I was looking at kernel.ubuntu.com/~kernel-ppa/mainline/v5.9.1
    – 8bitjunkie
    Oct 26, 2020 at 14:57

Late but new answer.

I will add some more information in my answer. Now my old kernel was linux-headers-4.8.0-53. To find out which kernel you have type uname -r in terminal. Now type this command to get list of available kernels.

apt-cache search linux-image

This will give you a very big output. Now chose one of them that you want to install and install it by following commands(Don't type these commands like this, replace the words kernal_version with the kernel version which you wish to install)

sudo apt-get install linux-image-kernal_version
sudo apt-get install linux-image-extra-kernal_version
sudo apt-get install linux-headers-kernal_version

Now in my case I choose linux-image-4.10.0-22-generic so my command will look like this

sudo apt-get install linux-image-4.10.0-22-generic 
sudo apt-get install linux-image-extra-4.10.0-22-generic
sudo apt-get install linux-headers-4.10.0-22-generic

Now in the end remove old kernel by command

sudo apt-get autoremove

Now when I first did it, I Don't know is it my hardware problem or because of removing the old kernel, but my laptop shows me black screen which happens to my laptop sometimes. Thus I remove it's battery and rebooted and typed the command. Also I don't suffer from my black screen issue any more.

uname -r

and it gives me


which means kernel is updated.

  • 4
    Yoour black screen issue may be because you removed the kernel in use. After you install the new kernel, you have to reboot. Then remove old kernel.
    – ravery
    Oct 2, 2017 at 3:05
  • 1
    Great answer. Although things have changed a little bit now, I had to change linux-image-extra into linux-modules-extra for version 4.18.0-22-generic to make this work.
    – deerchao
    Aug 27, 2019 at 12:08

There is a much simpler way of doing this, and it's the way I use. Simply download the Ubuntu Mainline Kernel Updater script and run it from a terminal. It will download the .deb's for you, install the new kernel, and optionally remove the old one (not recommended) then optionally reboot.

Example output (copied from my terminal):

evilsupahfly@the-black-beast:~$ sudo KernelUpdateChecker -no-rc -r utopic
Run this command to install the new kernel
root@the-black-beast:~# /tmp/kernel-update
Config Notes:
Rejecting Release Candidates
Accepting Latest Kernel
Accepting kernels compiled for utopic
Accepting kernels with a version higher than 3.15.0-031500-lowlatency

Kernel Version:
Release Date:
    2014/06/16 @ 18:41 (YYYY/MM/DD @ HH:MM)

Care to look at the change log? (y=Yes, n=No) (n)

(download output skipped)    

Greetings root
    I (the-black-beast) am now self aware and a sentient being, have a nice day.
    Oh and by the way SKYNET is now active.

Installing Linux 3.15.1-031501:

(installer output skipped)

The New Kernel looks to have been installed

WARNING: If the new kernel does not boot you may regret saying yes here.
Would you like to remove the current one? (y=Yes, n=No) (n): n

Are you ready to Reboot? (y=Yes, n=No) (n): n

Almost entirely automated, and completely problem free.

  • It was fine in 2014 when I posted the comment originally, however, since then, I've found it easier just to go with the answer @Bucic gave earlier - download the .debs to a folder (/home/evilsupahfly/Downloads/Kernels/X.XX-something/ in my case) and just do cd {.deb location} then dpkg -i *.deb in the terminal. No messing with PHP or SkyNet. Jun 28, 2020 at 20:02

I wrote a script and always will be up to date.

ukupgrade: Ubuntu Kernel Upgrade

  • Open your favorite terminal and run the follwing commands
  • Give executable permission to file

    chmod +x ./ukupgrade

  • Call the script


  • 1
    this was the best.
    – Ali
    Nov 3, 2016 at 12:02
  • keeps installing the low latency version when asking for generic~
    – user2413
    Mar 3, 2017 at 18:54
  • I didn't know about this tool so I also wrote a similar tool, which also supports selecting the generic/low latency flavor. You can find it here: github.com/cristim/kernel-update Jul 10, 2017 at 7:54
  • At this time, this script is broken and WON'T work. May 11, 2022 at 11:45

If you don't want to go through the hassle to manually upgrade the kernel you can try UUKU. Works fine even on Ubuntu derivatives like elementory, mint.

I used it to fix my WiFi issue as sometimes some new hardware won't be detected by old kernel. Other than hardware driver update I don't find the need to upgrade kernel. New kernels do have security and slight performance upgrade but also have tendency to break things like your VM.

sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install ukuu





Run the following Terminal commands to install a new Ubuntu mainline kernel.

sudo apt-get update
sudo apt-get install python-bs4 python-apt
cd /tmp
rm -rf medigeek-kmp*
wget https://github.com/medigeek/kmp-downloader/tarball/master -O kmpd.tar.gz
tar xzf kmpd.tar.gz
cd medigeek-*
python kmpd.py -d

The script is hosted at Github. Just press Enter instead of a number if you get stuck on a certain question in the Python script.

  • 3
    I'm the author of that script. I've just fixed it. Please file bug reports, most of the time programmers don't know bugs exist until someone files a report. :) Jul 19, 2013 at 19:29
  • What is the advantage of your script from just doing the install of the deb package like described by the best answer here?
    – rubo77
    Aug 7, 2014 at 2:27
  • I was just thinking of this type of tool since I crashed because apt did not install dependencies for me. You would think that apt was all about dependencies. Wrong. A script can be updated for the latest release or search for one and let the user choose. All that said, if I get my system up again, I will go direct since I found the terminal commands for rc6 Mar 4, 2016 at 15:21
  • @SavvasRadevic ImportError: No module named apt_pkg
    – Yahya
    Mar 11, 2019 at 10:37
  • 1
    @SavvasRadevic I already did, but just reporting as per your request.
    – Yahya
    Mar 23, 2019 at 20:42

Another option is to try customized and optimized builds, such as this i3/i5/i7 optimized 3.2.1 kernel for Ubuntu:

DuoPetalFlower, My Experiments with Linux - 3.2.1 kernel

He also has Intel atom optimized builds which can work quite well if you're trying to squeeze every last ounce of performance out of a netbook.

There are other kernels like Liquorix that claim to be better optimized for desktop performance.

Though not recommended by some, you can often run official kernels from later versions of Ubuntu without issues. I'm currently running the 3.3.3 precise kernel on oneiric and my machine works better than ever. Performance & battery life increased, while temperatures dropped a few degrees. My issue of a black screen when resuming from standby has also disappeared. Though I personally haven't had issues from using newer kernels, you will find some people who are strongly opposed to doing this.


As you've seen, Ubuntu does provide versions of the Linux kernel, but not always as fast as they are released upstream, you can always compile the 3.3.1 kernel yourself, but that may be more effort than you were looking for. If not, search around and I'm sure you'll find a tutorial you can follow such as this one. (note that I haven't checked that one thoroughly so be wary as kernels are dangerous beasts)


I created this script kernel-upgrade.sh that downloads and installs a selected kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline:

mkdir -p "$TMP" && cd "$TMP"
rm -f "$TMP"/*
R=$(wget -qO - "http://kernel.ubuntu.com/~kernel-ppa/mainline/$F/0005-debian-changelog.patch" | sed -ne '/^+linux/{s/.*\.\([0-9]\+\)).*/\1/p;q}')
set -x
wget "$URL/$F/linux-headers-$V-generic_${B}_amd64.deb" \
    "$URL/$F/linux-headers-${V}_${B}_all.deb" \
sudo dpkg -i "linux-headers-$V-generic_${B}_amd64.deb" \
    "linux-headers-${V}_${B}_all.deb linux-image-$V-generic_${B}_amd64.deb"
# now enter: sudo reboot now

In case Ubuntu doesn't start with the new kernel, you can select "advanced settings" in your grub menu and select to start the last running kernel there.

Note: since 4.15-rc7 the kernel has the KPTI fix against meltdown attacks and since 4.15.1 for "Spectre Variant 2, Mitigation 2" (check with http://github.com/speed47/spectre-meltdown-checker/)

  • I'm having some difficulty running this script. I may be doing something wrong, so here are my steps: 1. Disabled secure boot in BIOS, 2. saved the script to kernel-upgrade.sh, and chmod 777 kernel-upgrade.sh. I then ran it as sudo ./kernel-upgrade.sh. I then get the errors: rm: cannot remove '/var/tmp/kernel/*': No such file or directory; then ++ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16...<truncating url>` Connecting to kernel.ubuntu.com (kernel.ubuntu.com)||:80... connected. HTTP request sent, awaiting response... 404 Not Found` The 404 happens 3x Apr 14, 2018 at 2:19
  • the first warning by rm could be ignored (I added rm -f now). the rest is not clear, what is the problem. truncating url here is not helping, solving the problem. can you post the output in pastebin.com, so we can see what the resulting url would be?
    – rubo77
    Apr 14, 2018 at 16:41
  • sure, pasted over here pastebin.com/KcdVdKQr Apr 14, 2018 at 20:36
  • also if it matters, I am running ubuntu 17.10 Apr 14, 2018 at 21:04
  • It said this is the wrong path: kernel.ubuntu.com/~kernel-ppa/mainline/v4.16-rc6/… check this for the right path: kernel.ubuntu.com/~kernel-ppa/mainline/v4.16-rc6
    – rubo77
    Apr 17, 2018 at 21:28

to install the latest kernel install Ubuntu Kernel Update Utility

$ sudo add-apt-repository ppa:teejee2008/ppa

$ sudo apt-get install ukuu

disable access control with the following command:

$ sudo xhost +

then install with ukuu

$ sudo ukuu

$ sudo ukuu --install-latest

then run for secure

$ sudo xhost -

and reboot

$ sudo reboot

None of the above answers satisfied my problem of manually update the kernel to the latest stable version. (My current laptop is very sensitive to RCs, Dell XPS 9365).

I created a shell script that searches for more recent kernel versions and shows them as options to be installed. You can give it a try, it's on github, please be sure to read the README.


Actually I found a really easy commandline interface for upgrading which is hassle free, its a single bash script called ubuntu-mainline-kernel Install:

apt install wget
wget https://raw.githubusercontent.com/pimlie/ubuntu-mainline-kernel.sh/master/ubuntu-mainline-kernel.sh
chmod +x ubuntu-mainline-kernel.sh
sudo mv ubuntu-mainline-kernel.sh /usr/local/bin/

then for help

ubuntu-mainline-kernel.sh -h

or just checkout the README.md on the first link. Easy and doesn't install extra junk


There is a fork of UKUU, it is named Mainline, it is located at Github.
And installable from PPA as follows:

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt-get update
sudo apt-get install mainline

And then it will be available as mainline (CLI) and mainline-gtk (GUI).


Check Your Kernel Version $ uname -sr

Download Kernel v5 for 32 bit

$ wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/linux-headers-5.0.0-050000-generic_5.0.0-050000.201903032031_i386.deb
$ wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/linux-image-5.0.0-050000-generic_5.0.0-050000.201903032031_i386.deb
$ wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/linux-modules-5.0.0-050000-generic_5.0.0-050000.201903032031_i386.deb`

Download Kernel v5 for 64 bit

$ wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/linux-headers-5.0.0-050000-generic_5.0.0-050000.201903032031_amd64.deb
$ wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/linux-image-unsigned-5.0.0-050000-generic_5.0.0-050000.201903032031_amd64.deb
$ wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/linux-modules-5.0.0-050000-generic_5.0.0-050000.201903032031_amd64.deb`

Install it

$ sudo dpkg -i *.deb

Then Reboot

sudo reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .