This question is asked often in Ask Ubuntu, sometimes with few hints about the situation.

Please provide a list of possible reasons to help troubleshoot the problem.

  • 2
    This is a double post of Why Doesn't my Bootable USB Boot As this is the better post for the site, I suggest removing the other one to prevent this one being closed as a duplicate. You question has merit but double posts are not allowed.
    – Mark Kirby
    Dec 20, 2019 at 13:56
  • Would it be good to turn this into a "community post"? Jul 24, 2022 at 9:39

4 Answers 4


There are many reasons a persistent USB might not boot.


  • USB not set as first hard drive in BIOS

  • Problems with BIOS or UEFI boot partitions or files.

  • Secure Boot is not turned off

  • Drive not compatible with computers BIOS or UEFI boot mode

  • Incorrect partition table

  • Out of date BIOS/UEFI firmware

  • Junk in volatile memory

  • Fstab entry in Full install USB referring to HDD's efi boot partition on drives created on uefi machines.


  • Incorrect root partition in grub

  • Incorrect path to ISO in grub

  • Incorrect persistent-path, (if used), in grub

  • Grub menu entry structure not suiting OS

  • Incorrect file type for vmlinuz and initrd (.efi and .lz)

  • The word "persistent" is missing from grub.cfg, txt.cfg, syslinux.cfg or text.cfg

Persistence (casper-rw and home-rw)

  • Persistence partition is not an ext filesystem

  • Persistence file not on FAT filesystem

  • Persistence file/partition reused from different version

  • Persistence file full of data, or file update attempted


  • Corrupted flash drive, reformat and reload

  • Bad flash drive

  • Not enough RAM to run Ubuntu

  • Bad or incorrect USB socket

  • Incompatible computer CPU

  • Incompatible computer GPU

  • Computer does not meet minimum specs, a lighter version of 'buntu is required

  • Motherboard voltage irregularities

  • Motherboard BIOS limitation with multiple USB devices


  • Bad MD5SUM / corrupt ISO file

  • Modified or corrupted ISO9660 partition

  • USB was removed from computer before ISO file is completely copied

  • Out of date boot drive creation tool

  • User inexperienced with boot procedure

Thanks to karel and sudodus for help with the answer. See Why Doesn't my Bootable USB Boot


I know from experience that if a GUI USB creator like Rufus or Startup Disk Creator doesn't work then dd won't work either for the same (usually hardware-specific) reason. Sometimes it is possible to troubleshoot why a bootable USB doesn't boot if it is hardware specific (see below screenshots). For example, safe graphics is not working is a clue to an underlying hardware-specific problem. In this case enabling the nomodeset kernel boot option might work. Otherwise it is often possible to circumvent a hardware issue by installing Ubuntu using the lightweight, text-based Ubuntu minimal CD/USB.

More reasons not on the original list:

  1. Bad USB flash drive. This could even be a new flash drive which I assume to be not corrupted. Ubuntu will boot after making the Ubuntu live USB on a different USB flash drive. It's worth a try if you have two or more USB flash drives.

  2. Reformat the flash drive and reload the Ubuntu ISO from an application for making a live USB. If your hardware is very old try creating an Ubuntu Minimal USB for Ubuntu 20.04 and earlier.

  3. Check the Ubuntu ISO that you downloaded against its SHA256 checksum to verify that the checksums match.

  4. Voltage irregularities that affect the smooth amount of voltage delivered from the motherboard to the USB flash drive. Possible causes of this are motherboard, power supply and even irregular house current. A very old computer is more likely than a new computer to have issues with the motherboard or power supply that affect booting to a live USB session.

    Here are a few suggestions that worked when I tried them.

    1. Don't plug in USB devices like mouse and keyboard next to each other. Plug in one USB device at the front and one at the back. Or unplug the mouse entirely. You can also save power by temporarily disconnecting unused hard drives.

    2. Disconnect unnecessary devices when booting the USB to reduce the power load, for example disconnect one HDD if there are two drives. If you have a 4-port USB splitter with switches on each port this is ideal, because you can turn the USB mouse off when you don't need it and you don't need to open the computer case to disconnect an internal drive in order to reduce the power load.

    3. The Ubuntu live USB will sometimes be able to boot if the same computer is moved to another location that has a more controlled source of current or connected to an uninterruptible power supply (UPS).

  5. Overheating may cause the computer to power off when trying to start the Ubuntu installer. The CPU temperature can be checked by accessing the UEFI/BIOS setup utility when the computer is booting.

  6. Some applications for making Ubuntu live USBs seem to work better than others. For example, the built-in Startup Disk Creator application is more reliable than most bootable Linux live USB creator applications.

  7. In case the BIOS Boot options do not recognize the USB device at all, some older BIOSs do not even correctly label USB flash drives in the Boot options. Instead they use some non-standard nomenclature for flash drives like USB-FDD or USB-HDD. USB-FDD stands for "floppy disk drive" which never works with USB flash drives, so in this case you should choose USB-HDD instead. Even though a USB flash drive is not a hard disk drive choosing this option frequently works.

  8. Some BIOSs have not one but two options for USB flash drives in the Boot priority menu of the BIOS. One option is for UEFI USB and the other option is for Legacy or non-UEFI USB. Try selecting the other USB option (if there is one) in the BIOS Boot priority menu.

    Make sure the boot options in the BIOS/UEFI match with the ones on your Ubuntu live USB's boot options. For example, for UEFI without CSM boot the Ubuntu live USB with the UEFI without CSM option too.

(Click images to enlarge)


  • For #3, a laptop is a good alternate test system; laptop switching power supplies make very good filters, turning whatever wonky voltage coming from your wall into smooth (usually) 19VDC.
    – Doktor J
    Nov 22, 2019 at 16:43
  • I have also observed that current from laptop adapters is reliable.
    – karel
    Nov 22, 2019 at 17:03
  • @karel Thanks for the update. Mar 2, 2020 at 3:05

Great idea to create a list and a flowchart for this subject :-)

I would like to add

Problems with the UEFI/BIOS system of the computer, that it does not recognize a USB boot drive, that works in other computers:

  • the user does not know how to get to a temporary boot menu and how to get into the UEFI/BIOS menu system to modify the settings, should be possible to help when the computer brand name and model are known

  • secure boot might prohibit USB boot in general or a boot drive made without completely signed software, should be possible to turn off secure boot

  • the boot drive is not made for the boot mode of the computer
    • a BIOS mode booter will not boot in UEFI mode
    • an UEFI mode booter will not boot in BIOS mode (alias CSM alias legacy mode)
    • should work with USB drives cloned from Ubuntu iso files that can boot in UEFI as well as in BIOS mode except the mini.iso, which boots only in BIOS mode
  • junk in some volatile memory of the computer or connecting electronics after reboot, should work after shutdown and waiting for a minute.
  • quirk in some HP computers in BIOS mode, that will not boot via USB and grub with GPT, should be possible to fix by using an MSDOS partition table
  • some computers need an update of the UEFI/BIOS system. @oldfred often solves problems in Dell computers: "Dell typically needs UEFI update, SSD firmware update & change from RAID or Intel RST to AHCI for drive". Updating may help also with other computer brands

I've struggled with this since April. Virgin USB2 Stick with image from Ubuntu distribution. 64bit, 21.04. Created from standard Ubuntu 20.04 system. I'm trying to boot a 10 year old intel computer with nice hardware. The memory stick works on all of my other computers. SOLUTION: I went into my BIOS and increased the Hard Drive spin-up boot delay from zero to 10 seconds. (This computer doesn't even have a hard drive!) Everything booted normally and I'm now looking at the desktop with the Ubuntu Happy Hippo. Apparently, the USB2 stick boots too slowly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .