1

I am not the owner but in the same group as a file. The file has -rw-rw-r-- permissions, and:

beet ~> umask -S
u=rwx,g=rwx,o=rx

Over WinSCP, I am able to update the file but it produces this error:

error occurred while setting permissions and/or timestamp

Why is this happening and is there a way to overcome this?

1 Answer 1

0

Quoting WinSCP documentation for the error message:

You get this error, when a server fails to update file timestamp or permissions for some reason:

  • On some systems (e.g. Linux), you need to be an owner of the file (write permissions are not enough) to modify its permissions or timestamp (you will see an error like “Permissions denied” in error details).

...

Whatever the reason is, you need to turn off Set permissions and Preserve timestamp options or turn on Ignore permission errors.

2
  • I am aware of this. Is Ubuntu a Linux that permits owner only to modify timestamp?
    – Old Geezer
    Nov 22, 2019 at 8:41
  • I believe that all Linux systems do. Nov 22, 2019 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.