7

When I plug in my Cannon 50D camera with a USB cable into my laptop (running Ubuntu 19.10) and Shotwell pops up. But when I click on the 'Cannon Digital Camera' entry on the left sidebar an error message pops up that says,
"The camera is locked by another application. Please close any other application using the camera and try again."
I don't have any other applications open. Any ideas? It's not a fatal problem since I can access all the camera's photos with the file browser, but it's much for convenient to just click the little 'Import' button and have all my pics sorted by dates. Thanks.

10

I had the same symptoms with my Android phone, trying to import from it.

In file explorer, I could see that the device was mounted as a disk. I ejected it (unmounted, leaving it physically connected), and from there, shotwell was able to import my pics.

2
  • Yay, it works! Thanks a lot. – cajomar Jan 6 '20 at 2:18
  • 1
    This worked for me too! One more thing, it is better not to open the folder in the file explorer prior to ejecting it. Otherwise, it can still keep shotwell out of access even though the phone seems to disconnected in the explorer. – dojuba Apr 17 '20 at 14:00
1

Worked for me too iphone 4s, ubuntu 20.04, shotwell 0.8.3

  1. connected the phone
  2. unmounted the two disk «Documents sur […]» and «Iphone» from the dash
  3. opened Shotwell, clicked on my phone and imported

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.