1

I have a new Dell XPS 13 7390, with Ubuntu 18.04 (pre-installed by Dell).

Sometimes the touchpad stops working, and becomes completely unresponsive. So I cannot move the mouse pointer or click, but the laptop is responsive to the keyboard. This seems to happen randomly, but never when the laptop is plugged (so only on battery). Moreover, sometimes the touchpad starts working again after a few minutes, while other times I am forced to reboot the laptop.

Has anyone experienced a similar issue or know a fix?

1

A similar thing happened to me yesterday with the same computer. The main difference is that the touchpad stopped working full stop, and rebooting it does not change the situation. The touch screen still works instead. Any suggestion is welcomed!

  • 1
    Does it work on other OS? Windows or at least, live ubuntu system. Maybe it's a hardware problem? – Taras Khalymon Dec 6 '19 at 14:48
  • I tried a live Linux and it worked fine. So the problem is not in the hardware. – Giangiacomo Dec 11 '19 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.