I have a Lenovo Yoga 2 Pro notebook with 4 GB RAM, a high-DPI screen, Intel integrated graphics (Model 80AY000 but the motherboard was replaced for some lower model during a repair). It worked okay until recent upgrade. Now the UI stutter on every load spike, like when opening an app or even when switching between tabs in a browser.

I don't know how to troubleshoot this. I observed htop and iotop and they don't show anything suspicious, however, it might be because they are also freezed during those moments.

free -h
              razem       użyte       wolne    dzielone   buf/cache    dostępne
Pamięć:       3,8Gi       1,8Gi       363Mi       696Mi       1,6Gi       1,1Gi
Wymiana:       1,4Gi       293Mi       1,1Gi
ls -al ~/.local/share/gnome-shell/extensions
razem 44
drwxr-xr-x 11 pein pein 4096 lis 18 18:53 .
drwx------  3 pein pein 4096 lis 20 20:27 ..
drwxr-xr-x  5 pein pein 4096 lis 18 18:53 BingWallpaper@ineffable-gmail.com
drwxrwxr-x  5 pein pein 4096 paź  6 23:39 bitcoin-markets@ottoallmendinger.github.com
drwxrwxr-x  4 pein pein 4096 lis 10 00:20 desktop-icons@csoriano
drwxrwxr-x  5 pein pein 4096 paź  6 23:39 gnome-shell-screenshot@ttll.de
drwxrwxr-x  3 pein pein 4096 cze 21 20:28 gtktitlebar@velitasali.github.io
drwxr-xr-x  5 pein pein 4096 kwi  9  2019 no-title-bar@franglais125.gmail.com
# ^^^ this one is turned off, btw
drwxr-xr-x  4 pein pein 4096 kwi  9  2019 openweather-extension@jenslody.de
drwxrwxr-x  2 pein pein 4096 kwi 20  2019 transparent-gnome-panel@ttomovcik.com
drwxrwxr-x  2 pein pein 4096 maj  1  2019 transparentnotification@ipaq3870
dmidecode -s bios-version
cat /etc/fstab
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda8 during installation
UUID=dd3720dd-0a04-4ebd-901e-277e402697e0 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=9AE5-4726  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
/dev/sdb1       /home/pein                                ext4    rw              0       0
# ^^^ sdb1 is a USB3.0 flash stick

Tried running LiveUSB 19.10. It seems to be working fine.

SMART data of the disk

Tried answers from this question (upgrading kernel to 5.4 RC8, removing xserver-xorg-video-intel or installing it in version from ~oibaf ppa) with no success.

  • 3
    Edit your question and show me free -h and cat /etc/fstab and ls -al ~/.local/share/gnome-shell/extensions and sudo dmidecode -s bios-version, and tell me the specific make/model #'s of your notebook. Start comments to me with @heynnema or I may miss them. – heynnema Nov 20 '19 at 18:19
  • @heynnema updated – Pein Nov 20 '19 at 19:41
  • 1
    Please see my answer. Please remember to accept it if it solves your stuttering problem. – heynnema Nov 20 '19 at 21:29
  • 3
    Possible duplicate of Ubuntu 19.10 freezes and lags reguarly – WinEunuuchs2Unix Nov 21 '19 at 0:28
  • Indeed, seems like the same problem, but the answers didn't work in my case. – Pein Nov 21 '19 at 19:20

Pending answer...

You have BIOS version 76CN38WW. Your BIOS needs an update. Backup all of your important data first. Then go to https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/yoga-series/yoga-2-pro-lenovo/downloads/ds035004 and download and install BIOS version 76CN43WW. If the problem is solved, then you may be done.

"Stutters" can be caused by a faulty GNOME extension. Eliminate a GNOME extension problem by temporarily disabling ALL extensions that you see at https://extensions.gnome.org/local/. If the problem goes away, then enable one extension at a time until the problem returns. The last enabled extension would be the problem.

"Stutters" can be caused by swap problems. Your swap is too small for 4G RAM, and vm.swappiness parameter may need adjustment. Resize swap from 1.4G to 4G, and temporarily set sudo sysctl vm.swappiness=80. We'll set it permanently later.

"Stutters" can be caused by hard disk drive problems. Edit your question and show us screenshot(s) of the Disks application SMART Data window (it may take more than one screenshot to show all of the data).

| improve this answer | |
  • Neither of these helped, unfortunately. – Pein Nov 20 '19 at 21:59
  • @Pein There were 3 suggestions. Which ones did you try? – heynnema Nov 20 '19 at 22:03
  • All. I updated BIOS (the installer broke my GRUB, but I've fixed that already, nevermind), disabled all extensions, set /swapfile to 4GB and swappiness to 80. – Pein Nov 20 '19 at 22:12
  • @Pein edit your question with screenshot(s) of the Disks app SMART Data window. It may take 2 screenshots to get all of the data. Is your boot disk a HDD or SSD? – heynnema Nov 20 '19 at 22:17
  • 1
    I think the big issue here is it happened with the upgrade to 19.10 which brings with it a new kernel in addition to new gnome software. – WinEunuuchs2Unix Nov 21 '19 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.