1

GUII've read the three solutions on How to change time display to 12h time format in Ubuntu and set my time to 24 hour in the GUI and using gnome-tweak and I've managed to change my time and date format nicely, but cannot set 24 hour clock: the "AM" is still showing. This is in spite of

  1. "Time Format" being set to "24-hour" within the GUI, (see figure above)

  2. Entering in the command gsettings set org.gnome.desktop.interface clock-format '24h'

  3. and setting within browse to org > gnome > desktop > interface > clock-format within dconf-editor, and change the format to '24h'

How can I get the 24 hour clock format, is there some other setting that could be contradicting these three methods?

  • 1
    how did you set the time to 24 hour via GUI? can you attach a pic which is showing 24hr format with AM? – UnKNOWn Nov 20 '19 at 16:53
  • @PRATAP I've added a screenshot of the GUI. I followed Open Settings >Details> Date & Time. – con Nov 20 '19 at 16:59
  • yes.. thats clear.. can you post the output of this command? gsettings get org.gnome.shell enabled-extensions – UnKNOWn Nov 20 '19 at 17:01
  • @PRATAP con@VB:~/Pictures$ gsettings get org.gnome.shell enabled-extensions gives @as [] – con Nov 20 '19 at 17:04
  • gsettings get org.gnome.desktop.interface clock-format whats the output of this command? – UnKNOWn Nov 20 '19 at 17:07
2

since you are using GNOME-Flashback

run the below command

gsettings set com.canonical.indicator.datetime time-format 24-hour

for 12-hour

gsettings set com.canonical.indicator.datetime time-format 12-hour

or to reset to default value

gsettings reset com.canonical.indicator.datetime time-format

Alternatively you can use dconf-editor tool (sudo apt install dconf-editor)

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.