0

I'm trying to do run the command sudo apt-get install ssh, but when I do I get this error.

sudo apt error

$ sudo apt-get install ssh
Reading package lists... Done
E: The value 'jessie' is invalid for APT::Default-Release as such a release is not available in the sources

when I try to apt update to fix it I get this.

sudo apt update error

$ sudo apt update
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://ca.archive.ubuntu.com/ubuntu bionic InRelease                                              
Hit:3 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease                                      
Hit:4 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease              
Ign:5 http://cdn-fastly.deb.debian.org/debian jessie-backports InRelease                                       
Ign:6 http://cdn-fastly.deb.debian.org/debian stretch InRelease
Err:7 http://cdn-fastly.deb.debian.org/debian jessie-backports Release
404  Not Found [IP: 151.101.124.204 80]
Get:8 http://cdn-fastly.deb.debian.org/debian stretch Release [118 kB]
Get:9 http://cdn-fastly.deb.debian.org/debian stretch Release.gpg [2,365 B]
Ign:9 http://cdn-fastly.deb.debian.org/debian stretch Release.gpg
Reading package lists... Done 
E: The repository 'http://httpredir.debian.org/debian jessie-backports Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://cdn-fastly.deb.debian.org/debian stretch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7638D0442B90D010 NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY EF0F382A1A7B6500
E: The repository 'http://httpredir.debian.org/debian stretch Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The value 'jessie' is invalid for APT::Default-Release as such a release is not available in the sources

Anyone run into this before? Is there a way of just wiping apt dependencies and starting anew?

  • 1
    Hi, for the future, please post terminal information by copying and pasting the relevant output here using this site's markdown formatting. Posting images makes it difficult for responders to use part of the output in their answers or in requests for clarification. – Justice for Monica Nov 20 at 14:24
  • 4
    And why do you have Debian sources? – Justice for Monica Nov 20 at 14:25
  • good question, I don't remember trying to add debian sources, do you know how to remove them? – Paul Nov 20 at 14:27
  • Open Software and Updates and go to the Other tab. – To Do Nov 20 at 14:29
  • ok so I disabled the Debian sources, but still getting the "jessie" error – Paul Nov 20 at 14:33
2

I noticed a file /etc/apt.conf.d/10apt which had things about jessie in it and turned out to be causing my problem. Deleting that file resolved the issue.

  • 1
    How did you figure out that doing that would help? What was in the file? – Zanna Nov 20 at 15:56
  • 1
    I looked up what a typical /etc/apt.conf.d/ directory would look like for ubuntu, and it didn't include 10apt. I also tried editing the "jessie" value in 10apt to make sure that was the file that was restricting my apt calls, and it was. – Paul Nov 20 at 18:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.