I installed a new version of Ubuntu on my computer. Ubuntu 18.04.3 LTS

The files for my website are on another disk. See Program ToolsDisks

  • Device: /dev/sdb1
  • Partition type: Linux
  • Contence: Ext4(versie 1.0) – Mounted on /media/joris/doc

I did following ( source ):

sudo apt update
sudo apt install apache2
cd /etc/apache2/sites-available/
sudo cp 000-default.conf gci.conf

sudo gedit gci.conf
DocumentRoot media/joris/doc/website

sudo a2ensite gci.conf
service apache2 reload

sudo adduser joris  www-data
sudo chown -R www-data:www-data /media/joris/doc/website
sudo chmod -R g+rw /media/joris/doc/website

P.S. I live in Belgium and I speak Dutch. Exist also a dutch forum of Ubuntu?

I have taken new steps I encountered problems with rights in other programs

mkdir /d sudo cp etc/fstab etc/fstab_oud
sudo gedit etc/fstab

# Harde schijf 1TB
UUID="23f455e3-08a4-4e34-9122-19e375ed6a4c" /d ext4 defaults 0 0

Folder website: /d/website

cd etc/apache2/sites-available
sudo gedit gci.conf

# DocumentRoot /var/www/html
  DocumentRoot /d/website

sudo gedit etc/apache2/apache2.conf Options Indexes FollowSymLinks AllowOverride None Require all granted

With the program dolphin I added a named user www-data

I have added named user www-data and [v] Apply changes to all subfolders and their content

service apache2 reload

My site is still not displayed, but the default site of apache!


Problem is solved!!

I did this:

joris@joris-MS-7798:/etc/apache2/sites-available$ sudo a2dissite 000-default
[sudo] wachtwoord voor joris:
Site 000-default disabled.
To activate the new configuration, you need to run:
systemctl reload apache2
joris@joris-MS-7798:/etc/apache2/sites-available$ sudo a2ensite gci.conf
Site gci already enabled
joris@joris-MS-7798:/etc/apache2/sites-available$ sudo service apache2 reload

And it worked!!

| improve this answer | |
  • So what was the problem? Did you edit gci.conf in between? Or did you just forget sudo in your original service apache2 reload command? – Melebius Jan 28 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.