1

I'm having a bit of a weird issue.

We recently got some ex-DC Dell R210 1U servers with Matrox® G200eW video for our development lab at work, and we're looking at using some of them as workstations. I managed to get Ubuntu 19 installed on one to test it out, everything seems to be fine, except that the mouse icon isn't showing. The mouse appears to be working, I can see it light up application icons on the menu bar and within programs, but the actual cursor doesn't show up.

I've had a look online, found a couple of things that people have tried on previous versions of Ubuntu, however they've not worked for me.

1) systemctl restart lightdm / gdm

lightdm wasn't installed, gdm restarted, no mouse icon.

2) Change DE

Installed and switched to Cinnamon (which I was planning on doing anyway), no mouse icon

3) gsettings set org.gnome.settings-daemon.plugins.cursor active false

The page I found that had the above command on was for Ubuntu 14.04, however it had worked on "newer versions". No specificity as to which versions. I tried that with and without sudo, with and without a reboot, but still no icon.

I can't see anyone else having this issue, so I wonder if its a hardware thing rather than an Ubuntu thing, but thought I would ask first just in case I'm missing something.

Kind Regards,

B

0

One source suggested, for a different video problem, editing /etc/X11/xorg.conf to contain:

Code:
Section "Device"
        Identifier      "Configured Video Device"
        Driver          "vesa"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

A second and third source mentioned obtaining Matrox video drivers:

mkdir xserver  
cd xserver  
apt-get source xserver-xorg-video-mga  
apt-get install dh-autoreconf xserver-xorg-dev x11proto-video-dev x11proto-fonts-dev x11proto-xf86dri-dev quilt xutils-dev  

Should those suggestions not help, please try booting from a LiveUSB of Xubuntu 18.04 LTS and see if that resolves the issue.

  • Hi @K7AAY. I tried following the second source you listed for the rebuilding of the mga drivers. No such luck. I've installed 18.04.3 LTS on to the device for now, and the mouse is working perfectly. I think this server will live on that version for now, and I'll try the other steps on a different device over the next couple of weeks. Thanks for your help. – user1017340 Nov 20 '19 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.