0

How to disable Alt-LeftMouseButton dragging in KDE?

Setting Window Management / Window Behavior / Window Actions / Inner Windows, Titlebars & Frame / Left Button to "Nothing" doesn't help.

What else can be done?

enter image description here

I am accessing machine via VNC.

  • It took me quite a while to figure out "LMB" meant "left mouse button". – Kenneth Hanson Nov 25 '19 at 5:16
  • Are you trying to disable Alt+Drag on the remote machine, or your local machine? Also, is there a specific problem that the feature is causing? I'm trying to come up with ideas for troubleshooting. – Kenneth Hanson Nov 25 '19 at 5:30
  • @KennethHanson sorry for misunderstanding; there is a suitable feature of Jetbrains IDEs, allowing to make vertical selections in editors with Alt LMB. I can't use this feature, because it starts to drag window. – Dims Nov 25 '19 at 8:30
  • Maybe you've found a bug! But as a workaround, does changing the modifier key from Alt to Meta help? – DK Bose Nov 26 '19 at 4:19
0

I'm using Xubuntu 18.04 LTS, but I assume it will be the same solution: All settings > Window Manager Tweaks > Accessibility > 'Key used to grab and move windows'.

0

I can't replicate your problem on my machine (Kubuntu 19.04 + KDE backports PPA), but here are some troubleshooting ideas:

  • Make sure you pressed the Apply button at the button of the setting window.
  • I assume you are using this IDE on the remote machine, but you haven't mentioned whether you you tried to disable Alt+Drag on the remote machine or the local machine, only "it starts to drag [the] window". But it's not clear whether this is the VNC window or the IDE window. Make sure you have changed the setting on the correct machine. You may very well need to do it on both.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.