0

I just upgraded (fresh install) to the new Lubuntu 19.10. Same as in the previous versions, the nm-applet does not run on startup. The nm-applet is the GUI for the Network Manager and I need it to set up a VPN connection.

What I usually do is to start it manually using sudo nm-applet and then I can proceed to set up my VPN connection.

Any ideas why this is happening? If you need any more information, just ask. This really is just a fresh install of 19.10. The problem was always present on every Lubuntu version 18.04 onward. I just always used the terminal to launch it manually. It works, but it's bothersome.

EDIT 19.11.19: I did, as described, perform a fresh installation with a bootable USB drive and the newest version of Lubuntu. Actually, I blanked the disk (HDD not SDD) before with DBAN because I was dealing with sensitive financial information. There was absolutely no trace left on the drive of the previous install.

I confirm the problem existed with 18.04 too. That was the first version of Lubuntu I tried and I always had to use "sudo nm-applet". I know for sure, because it gave me a headache to find out what was wrong. However I am not going to switch distro just because of this issue.

I am confident you can try Lubuntu 19.10 in your VM and have the same result. (nm-applet) not displaying/started. As a matter of fact, I just tested on my spare DELL notebook with another new install with the same result.

  • 1
    fyi: Lubuntu 18.04 is very different to later releases (you say 18.04 onward so I take it as including 18.04) thus I suspect it's not Lubuntu specific but generic. Lubuntu 18.10 onward used LXQT & calamares installer, where as Lubuntu 18.04 and before used ubiquity & LXDE. Did you mean to include 18.04? and when you mean 'clean' do you mean format of all partitions? (ie. what I'd call 'clean') or install into (Manual partitioning & no-format of /home, or even / drives; this will cause system directories to be wipes yes, but not user configs which I wonder is your issue & why it repeats) – guiverc Nov 19 at 1:26
  • "I just upgraded (fresh install) to the new Lubuntu 19.10." Please clarify. Did you upgrade an existing version of Lubuntu to 19.10? Did you do a clean install overwriting an existing install? If it's the latter, did you retain your home folder or import some .dot files/folders from the previous installation? – Justice for Monica Nov 19 at 1:55
  • I added more information in my original post via editing it. – Velvia Nov 19 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.