1

I tried follow steps which worked in 18.04 but it does not work for 19.10:

    Create a file /etc/dconf/pofile/local with following content:
    # cat /etc/dconf/pofile/local
    user-db:user
    system-db:local

    Create a file /etc/dconf/db/local.d/00-media-automount with following content:

    # cat /etc/dconf/db/local.d/00-media-automount
    [org/gnome/desktop/media-handling]
    automount=false
    automount-open=false

    After creating the file, apply the changes using below command :

    # dconf update


In 18.04 we can find the new rules in dconf dump / but in 19.10 it does not show the newly added rules in local.d. dconf-editor still give true for those 2 values which are the defaults.

Any idea how to make the gnome respect local.d again?

0

Ah, I just figured it out. The DCONF_PROFILE has to be set to the profile file name. Here it needs to be local. If it is not set, by default it is looking for /etc/dconf/profile/user. Thus change the file name to user is a better choice.

| improve this answer | |
0

easier option: run dconf-editor, go to org.gnome.desktop.media-handling

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.