I used Rufus 3.8p to write Ubuntu-18.04 on to a SanDisk 32GB pen drive. I am trying to loading into the Ubuntu live gparted so I can resize my partition.

I get these options when botting into the pen drive.

* Try Ubuntu without installing
* Install Ubuntu

Regardless of what I choose, I get these warnings.

ACPI Bios Error (bug)
unable to enumerate USB device

Then the Ubuntu splash screen appears with a loading indicator. Then I am back on the command line with an error.

(initramfs) Unable to find a medium containing a live file system

My system is Dell XPS 15 9570. Different settings in my BIOS. Boot List Option is set to UEFI rather than Legacy External Devices. I have tried changing this. But I get more errors. Secure Boot is Off.

I have tried changing USB ports. I read somewhere about using USB 2.0 instead of USB 3.0. But, there are no USB 2.0 ports, and I don't think there is an option to change it in the BIOS.

All I want to do is get to gparted so I can resize my drive. I have tried to install a bootable version of gparted into a USB drive. It boots but then runs into a similar error.


Tried disabling ACHI. Didn't fix the original issue. But now when I set it back to AHCI, the grub menu has completely dissappeared. System directly boots into Windows. I didn't mention before, but I have Win 10/Ubuntu 18.04 dual boot. This is going to be a long day.

  • If you want to use GParted on a Live USB to modify that USB you may need to boot toram. When booting press shift key, then esc key at languages then F6 key and esc key again. then type a space and "toram". you can now use GParted to modify the partitions. – C.S.Cameron Nov 18 '19 at 4:21

Issue 1: (initramfs) Unable to find a medium containing a live file system

My boot USB was set to MBR while my system was GPT. I created a new boot USB with GPT setting.

Issue 2: USB was not listed under BIOS boot devices.

I always had Secure Boot off. For some reason, I had to set Secure Boot On, then restart, boot into windows, shutdown, and then go into BIOS, set Secure Boot Off, restart, then USB appeared. Weird. Not sure what's going on there.

Issue 3: Ubuntu grub menu is not available. Machine boots directly into Windows.

Once I could boot into the live USB, I used the boot repair tool as described here to get GRUB back.

Issue 4: Resizing ubuntu partition

Once you have access to the live USB, it is easy to start gparted and change partition size.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.