So I upgraded my linux distribution recently from 16.x LTS to 18.04 LTS and I can't suspend my computer anymore.

At first the button didn't even appear on the nav bar (Gnome related pb) so I installed the suspend button extension provided here: https://extensions.gnome.org/extension/826/suspend-button/ and now I can see the || (pause) button as desired. But this simply shut down my computer instead of suspending it.

I tried to manually close my laptop screen but this also shut down my computer when it used to suspend it with ubuntu 16 LTS :/

I finally tried to deal with it with the terminal:

sudo pm-suspend #but shut down my computer as well

sudo pm-suspend-hybrid #but just doesn't work (the screen turns black but the computer keeps working, the fan being noisy)

As I resized my partitions while upgrading from 16 LTS to 18.04 LTS, I'm wondering if the problem could possibly come from there(Maybe I did something wrong?). Here is a screenshot of my hard drives configuration (In particular I don't understand why there is a star present in the Boot column in the sda1 row when my Ubuntu is installed on sda5.

Thanks a lot in advance for your help! This is quite annoying for me being forced to shutdown my computer every time I go for a break :/

NB: Please do not hesitate to ask for further info If I'm not clear enough in what I am asking :-)

boot/hard drive configuration

EDIT: I checked the Tweaks option and "Suspend when laptop lid is closed" is on so the problem doesn't come from there. (cf screenshot) enter image description here

EDIT2: I tried to switch back to unity as advised but the problem still persists. Suspend button simply shutdown the computer whether I'm using Gnome or Unity.

EDIT3: I noticed that the pm-suspend command generate a .crash file when executed (I guess this one is generated during the few seconds between the execution of the command and the shutdown of my computer) Here is the report on a drive .txt file (was not too sure how to share it with you as it is really long) https://drive.google.com/file/d/1mwWwlCmOMJ05Dw9aiWC-X5pZ0hWWy_Rf/view?usp=sharing

EDIT4: I'vs got some new stuff. I changed my GPU driver from a proprietary NVIDIA driver to X org X server (cf screenshot) and now suspend is working again. I'm not really sure if I will be able to use my GPU with this open source driver but at least I have identified a possible root cause of the problem. I tried sudo systemctl hibernate and it still doesn't work though but at least suspend is back to normal.

GPU driver changes

EDIT5: I tried all the nvidia drivers available on the GUI software&updates panel and one of them let me suspend my laptop without any trouble (the 390 one cf screenshot) enter image description here

So the question is now what's up with the Nvidia driver? Why hibernate is still not working ?

  • 1
    When you login you can select the gear next to the password and choose "Unity" desktop so you can operate in a more familiar environment within 18.04. Then you can choose the system settings for Power Management and Shutdown menu will contain the Suspend option like you are used to. Nov 17, 2019 at 15:06
  • 1
    Is Secure Boot disabled in BIOS?
    – Pilot6
    Nov 17, 2019 at 15:10
  • @WinEunuuchs2Unix I can't see any gear next to the password at login screen :/
    – Jeanba
    Nov 17, 2019 at 15:12
  • @Pilot6 I just restarted my computer and browsed the BIOS. I don't have any secure Boot option. Is it normal ? :/
    – Jeanba
    Nov 17, 2019 at 15:18
  • 1
    It is normal if your system is non-UEFI.
    – Pilot6
    Nov 17, 2019 at 15:19

1 Answer 1


How to select Unity desktop in Ubuntu 18.04

When you were running Ubuntu 16.04 you were on the Unity interface. After upgrading to 18.04 the Unity interface is still there but new interfaces are offered as well. It sounds like you are searching for the Gnome Desktop which you can select from the "gear" next to the Sign In button during login:

Ubuntu 18.04 Five Desktops.jpg

You can try all the desktops to see which you like best but keep in mind:

  • Many have reported problems using the Wayland window manager which was designed to replace X11 but has not lived up to expectations.
  • When I tested 18.04 upgrade of 16.04 clone some of the options resulted in a purple screen with only a movable mouse cursor.

Can't be sure at this time but it sounds like this:

  • I don't have such a gear button :/
    – Jeanba
    Nov 17, 2019 at 15:37
  • Ok my bad, when restarting my computer I have it indeed, thanks! I switch back to unity but the "shutting down instead of sleeping' problem persists. :/
    – Jeanba
    Nov 17, 2019 at 15:47
  • @user8119313 Short press the power button and see if it suspends properly. Nov 17, 2019 at 15:54
  • Just tried it. This opened a pop-up asking me if I wanted to suspend, lock, shutdown or restart my computer. Clicking the "suspend" option shut-downed my computer once again.
    – Jeanba
    Nov 17, 2019 at 16:00
  • 1
    @user8119313 I can read the crash report OK. I'm not good at interpreting it though. Hopefully someone while shortly! Nov 17, 2019 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.