0

I'm trying to create a new Raid 5 array on my system using 3 12TB Seagate Exos drives on a Ubuntu Server 18.04 install. At first I just tried to use Webmin and created a GPT partition on each of the drives then tried to create an array but it immediately started in degraded mode while still showing all three disks still in the array. I looked at the log in kern.log and it showed the array was active with 2 out of 3 devices and was in recovery mode.

That didn't seem right so I deleted the array and tried at the command line. I used fdisk to re-create the patriation table and tried to create the raid using the following command:

~$ sudo mdadm --create --verbose /dev/md0 --level=5 --raid-devices=3 /dev/sda /dev/sdb dev/sdd

and got the following return:

mdadm: layout defaults to left-symmetric
mdadm: layout defaults to left-symmetric
mdadm: chunk size defaults to 512K
mdadm: partition table exists on /dev/sda
mdadm: partition table exists on /dev/sda but will be lost or
       meaningless after creating array
mdadm: partition table exists on /dev/sdb
mdadm: partition table exists on /dev/sdb but will be lost or
       meaningless after creating array
mdadm: cannot open dev/sdd: No such file or directory

I tried changing the SATA cables and SATA ports thinking that could be a problem but that wasn't it. I thought it was initially a bad disk but as I switched SATA ports the drive that was left out would occasionally change (verified by checking serial numbers) so I'm at a loss as to what could be causing this and had hope someone knew what was going on and could help.

Here is what Webmin shows:

Device file    /dev/md0
UUID    6981f19f:731e442b:f8c8e8e2:c47a8729
RAID level    RAID5 (Distributed Parity)
Filesystem status    Active but not mounted
Usable size    23437503488 blocks (21.83 TB)
Persistent superblock?    Yes
Layout    left-symmetric
Chunk size    512 kB
RAID errors    1 disks have failed
RAID status    clean, degraded, recovering 
Rebuilding progress    0 % (1447.9 min, 131 MB/s)
Partitions in RAID    SATA device A partition 1 
                      SATA device B partition 1 
                      SATA device D partition 1 
  • I just found a post on another site from 2009 that stated "When creating a RAID5 array, mdadm will automatically create a degraded array with an extra spare drive. This is because building the spare into a degraded array is in general faster than resyncing the parity on a non-degraded, but not clean, array. This feature can be overridden with the --force option." Is this true? If it is, I still don't understand why it won't create the array from the command line? – Landmine Nov 17 '19 at 4:25
  • Ok, I just booted into an old Ubuntu Server 14.04 drive that I have and I can create the array from the command line there but it shows up as clean, degraded, recovering in webmin. I'm all sorts of confused now as to why it won't work from the command line in Ubuntu Server 18.04. – Landmine Nov 17 '19 at 4:29
  • See your first mdadm command : create --verbose /dev/md0 --level=5 --raid-devices=3 /dev/sda /dev/sdb dev/sdd a slash is missing – cmak.fr Nov 17 '19 at 4:40
  • Wow, I've been trying to figure this out all day and low and behold it's just that simple! Thank You! – Landmine Nov 17 '19 at 5:02
0

It looks like it was just as simple as a missing slash. Thanks cmak.fr!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.