So I configured ARM and it was working correctly for flac files. However when I set it up for mp3 (I am doing it for someone else end they prefer mp3) it is not working.

As for the logs:

[2019-11-17 00:01:17] INFO ARM: Starting ARM processing at 2019-11-17    00:01:17.3539
[2019-11-17 00:01:17] INFO ARM: ARM version: 2.0.1-stable
[2019-11-17 00:01:17] INFO ARM: Python version: 3.6.8 (default, Oct  7 2019, 12:59:55) [GCC 8.3.0]
[2019-11-17 00:01:17] INFO ARM: Looking for log files older than 1 days old.
[2019-11-17 00:01:17] INFO ARM: Starting Disc identification
[2019-11-17 00:01:17] INFO ARM: Mounting disc to: /mnt/dev/sr1
[2019-11-17 00:01:21] INFO ARM: **** Logging ARM variables ****
[2019-11-17 00:01:21] INFO ARM: devpath: /dev/sr1
[2019-11-17 00:01:21] INFO ARM: mountpoint: /mnt/dev/sr1
[2019-11-17 00:01:21] INFO ARM: videotitle: 
[2019-11-17 00:01:21] INFO ARM: videoyear: 
[2019-11-17 00:01:21] INFO ARM: videotype: 
[2019-11-17 00:01:21] INFO ARM: hasnicetitle: False
[2019-11-17 00:01:21] INFO ARM: label: LimpBizkitECD
[2019-11-17 00:01:21] INFO ARM: disctype: music
[2019-11-17 00:01:21] INFO ARM: **** End of ARM variables ****
[2019-11-17 00:01:21] INFO ARM: **** Logging config parameters ****
[2019-11-17 00:01:21] INFO ARM: skip_transcode: False
[2019-11-17 00:01:21] INFO ARM: mainfeature: True
[2019-11-17 00:01:21] INFO ARM: minlength: 600
[2019-11-17 00:01:21] INFO ARM: maxlength: 99999
[2019-11-17 00:01:21] INFO ARM: videotype: auto
[2019-11-17 00:01:21] INFO ARM: ripmethod: backup
[2019-11-17 00:01:21] INFO ARM: mkv_args: 
[2019-11-17 00:01:21] INFO ARM: delrawfile: True
[2019-11-17 00:01:21] INFO ARM: hb_preset_dvd: High Profile
[2019-11-17 00:01:21] INFO ARM: hb_preset_bd: High Profile
[2019-11-17 00:01:21] INFO ARM: hb_args_dvd: --subtitle scan -F
[2019-11-17 00:01:21] INFO ARM: hb_args_bd: --subtitle scan -F --subtitle-burned --audio-lang-list eng --all-audio
[2019-11-17 00:01:21] INFO ARM: logfile: /home/arm/logs/LimpBizkitECD.log
[2019-11-17 00:01:21] INFO ARM: armpath: /home/arm/Desktop
[2019-11-17 00:01:21] INFO ARM: rawpath: /home/arm/media/raw/
[2019-11-17 00:01:21] INFO ARM: media_dir: /home/arm/media/movies/
[2019-11-17 00:01:21] INFO ARM: extras_sub: extras
[2019-11-17 00:01:21] INFO ARM: emby_refresh: False
[2019-11-17 00:01:21] INFO ARM: emby_server: 
[2019-11-17 00:01:21] INFO ARM: emby_port: 8096
[2019-11-17 00:01:21] INFO ARM: notify_rip: True
[2019-11-17 00:01:21] INFO ARM: notify_transcode True
[2019-11-17 00:01:21] INFO ARM: **** End of config parameters ****
[2019-11-17 00:01:21] INFO ARM: Disc identified as music
[ERROR] abcde: mp3gain is not in your path.
[INFO] Define the full path to the executable if it exists on your system.
[INFO] Hint: sudo apt-get install 
[2019-11-17 00:01:21] ERROR ARM: Call to abcde failed with code: 1(b'')
[2019-11-17 00:01:21] INFO ARM: Music rip failed.  See previous errors.  Exiting.

it seems there is wrong path to an mp3 encoder, however when i look at abcde.conf file the path seems alright to me.

# -----------------$HOME/.abcde.conf----------------- #
# A sample configuration file to convert music cds to 
#       FLAC using abcde version 2.7.2
#       http://andrews-corner.org/abcde.html
# -------------------------------------------------- #
# This script was copied from the above site with the following modification:
# Set to non-interactive
# CDDMETHOD=cddb since it's more reliable (for my CDs)
# Enabled getalbumart
# Change output format from artist-album to artist/album


# Encode tracks immediately after reading. Saves disk space, gives
# better reading of 'scratchy' disks and better troubleshooting of
# encoding process but slows the operation of abcde quite a bit:

# Specify the method to use to retrieve the track information,
# the alternative is to specify 'cddb':

# Make a local cache of cddb entries and then volunteer to use 
# these entries when and if they match the cd:

# Specify the encoder to use for FLAC. In this case
# flac is the only choice.
# Specify the path to the selected encoder. In most cases the encoder
# should be in your $PATH as I illustrate below, otherwise you will 
# need to specify the full path. For example: /usr/bin/flac
# Specify your required encoding options here. Multiple options can
# be selected as '--best --another-option' etc.
# Overall bitrate is about 880 kbs/s with level 8.
FLACOPTS='-s -e -V -8' 
LAMEOPTS='--preset extreme'

# Output type for FLAC.

# The cd ripping program to use. There are a few choices here: cdda2wav,
# dagrab, cddafs (Mac OS X only) and flac. New to abcde 2.7 is 'libcdio'.

# Give the location of the ripping program and pass any extra options,
# if using libcdio set 'CD_PARANOIA=cd-paranoia'.

# Give the location of the CD identification program:       

# Give the base location here for the encoded music files.

# The default actions that abcde will take.

# Decide here how you want the tracks labelled for a standard 'single-artist',
# multi-track encode and also for a multi-track, 'various-artist' encode:

# Decide here how you want the tracks labelled for a standard 'single-artist',
# single-track encode and also for a single-track 'various-artist' encode.
# (Create a single-track encode with 'abcde -1' from the commandline.)

# Create playlists for single and various-artist encodes. I would suggest
# commenting these out for single-track encoding.

# This function takes out dots preceding the album name, and removes a grab
# bag of illegal characters. It allows spaces, if you do not wish spaces add
# in -e 's/ /_/g' after the first sed command.
mungefilename ()
  echo "$@" | sed -e 's/^\.*//' | tr -d ":><|*/\"'?[:cntrl:]"

# What extra options?
MAXPROCS=2                              # Run a few encoders simultaneously
PADTRACKS=y                             # Makes tracks 01 02 not 1 2
EXTRAVERBOSE=2                          # Useful for debugging
COMMENT='abcde version 2.8.1'           # Place a comment...
EJECTCD=y                               # Please eject cd when finished :-)

Do you have any ideas what might be missing?

Edit: I'm on Ubuntu 18.04

Edit2: I pasted logs two times instead of logs and abcde.conf now fixed.

  • Looks like your copy of abcde is missing mp3gain, which is not available in 18.04. You should have access to a configuration file here: /home/arm/.abcde.conf, can you post the contents of this file? It will then be easy enough to remove the offending lines...
    – andrew.46
    Nov 16, 2019 at 23:57
  • That's what I meant to do, but pasted two times logs. Now it's edited.
    – Adures
    Nov 17, 2019 at 0:28
  • 1
    I recognise the conf file as an edited one from an older version of my web site :). Under 'ACTIONS' remove 'replaygain,' and then all should be well...
    – andrew.46
    Nov 17, 2019 at 0:43

1 Answer 1


The problem comes from your .abcde.conf file where you have specified the following:


The offender is replaygain, which works well enough when you are encoding to flac as abcde uses metaflac to add the replaygain information. However when you are encoding to mp3 abcde calls for a replaygain application called mp3gain which is no longer available in Ubuntu 18.04.

The easiest fix is to simply omit the replaygain 'action' as follows:


And then all should be well...

  • Thank you so much for your help. And for explanation.
    – Adures
    Nov 17, 2019 at 7:58
  • 2
    @Adures And all the best with abcde (and ARM). I was a developer for abcde for a few years and it is good to see this great application still in use :)
    – andrew.46
    Nov 17, 2019 at 9:24
  • Wha can i say, that project is a godsend for me. I have few hundred CDs to rip. Thanks again :)
    – Adures
    Nov 18, 2019 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.