4

I'm trying to install Flash CS 6 Pro (which is now called Adobe Animate) for Windows with Wine 4.0.2 on Ubuntu 18.04.3 LTS. I installed the latest version of Wine, updated all repositories and restarted Ubuntu.

This is the error I get after running wine setup.exe from the command line.

do@b:~/Desktop/Flash Pro CS6/Adobe Flash Professional CS6$ wine setup.exe
0009:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
0009:fixme:font:get_outline_text_metrics failed to read full_nameW for font L"Ani"!
0009:fixme:nls:GetThreadPreferredUILanguages 00000034, 0x33e004, 0x33e074 0x33e00c
0009:fixme:nls:get_dummy_preferred_ui_language (0x34 0x33e004 0x33e074 0x33e00c) returning a dummy value (current locale)
0009:fixme:wuapi:update_installer_get_IsBusy 
0009:fixme:wuapi:update_installer_get_RebootRequiredBeforeInstallation 
0009:fixme:shell:InitNetworkAddressControl stub
0029:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
002c:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
002c:fixme:font:get_outline_text_metrics failed to read full_nameW for font L"Ani"!
002c:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
002c:fixme:nls:get_dummy_preferred_ui_language (0x8 0x33d370 (nil) 0x33d374) returning a dummy value (current locale)
002c:fixme:nls:get_dummy_preferred_ui_language (0x8 0x33d370 0x1940e8 0x33d374) returning a dummy value (current locale)
002c:err:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request failed with status 0x2733
002c:err:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request failed with status 0x2733
do@b:~/Desktop/Flash Pro CS6/Adobe Flash Professional CS6$ 002c:fixme:imm:ImmReleaseContext (0x1008e, 0x1f4bfe0): stub

It should work on Ubuntu based on this post on winehq.org. How to fix this error?

0

As indicated by the post you linked to, Adobe Flash CS6 (12.0) has been tested to work well with Wine version 4.02 The latest (development version of wine is at the moment of writing this answer, 4.20) SO if you are truly using version 4.02 of wine it's been tested to work. I recommend that you issue the wine --version to confirm the version of wine that you are actually using matched the tested version of 4.02. Another possible gotcha here, is that you are using Adobe Animate which granted was a renaming of Flash CS 6, but to the best of my knowledge wasn't announced until 2015 While the version partially tested as working with wine (adding extensions was NOT tested) was released in 2012. It appears that counting major and minor revisions there have been at least 10 revisions since that tested version came out.

Also note that there are specific instructions for running Windows programs from the command line under wine. that don't appear to have been followed.

If you've confirmed that your version of wine AND your version of Adobe Animate match the versions tested, this problem might be related to utilizing the wrong wine prefix The numerous :fixme: errors indicate bugs in wine support for the version of Adobe Animate that you are attempting to run.

You might also be attempting to utilize the wrong wine prefix for your version of Adobe Animate.

If none of this information proves to be useful, your best bet will be to contact those more directly involved in the project. There's a wine help forum here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.