You've heard this a million times but the "tap to click" is a pain in the behind and I want to disable it. There is no touchpad in gpointing-device-settings and neither in mouse and touchpad in system settings. I've tried some commands in terminal but it's all crap. Dconf-editor doesn't react. How about solving this once and for all?

Comp: Dell inspiron N5110

xinput list:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD               id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]


I think someone fixed it here on launchpad

Can someone explain the fix like I was a four year old idiot? (using precise pangolin)

  • I have a little script that works for me and probably works for you. I will post it for you later today when I am home. ;) Commented Apr 5, 2012 at 2:12
  • what do you get when you run `xinput list'? Please paste it somewhere all the output. Commented Apr 5, 2012 at 14:47
  • Possible duplicate? askubuntu.com/questions/117010/…
    – fossfreedom
    Commented Apr 5, 2012 at 22:24
  • 1
    Well it's multiplicate because there doesn't seem to be a solution for all.
    – AWE
    Commented Apr 10, 2012 at 21:52
  • Can you add the model laptop to your question? Perhaps we can narrow this down a bit. Commented Apr 11, 2012 at 4:16

6 Answers 6


Type this into the terminal:

synclient MaxTapTime=0

But it will only work for the session, unfortunately.

I have also found this which I have now tried myself

Essentially it is a way to put the synclient settings MaxTapTime=0 into an executable file (I personally don't like fixes which involve installing GUIs on lubuntu - the whole point of it is lightness.

I have now found that there is a way to get a .sh file to come on at startup in lubuntu see this thread where I asked about it.

If you type


Into terminal. This will bring up all the possible settings for the touchpad, so you can potentially do more tweaking.


All Settings--> Mouse and Touchpad --> uncheck "tap to click"

Settings / Mouse & Touchpad / Tap to Click

The image is from Ubuntu 16.04 as it appears on a Lenovo Thinkpad T460.

I disabled 'tap to click'. I use the touch pad buttons for clicking. This makes my life much better with Ubuntu and Mint.

  • 6
    Unfortunately not all setups have this option (as apparent in the 2nd sentence of the question).
    – danja
    Commented Apr 5, 2016 at 15:04

I just tried a the Wayland Gnome session on 17.04 and I noticed that it has many more touchpad options than the X11 session – including a persistent tap-to-click setting:

enter image description here


In my Ubuntu 12.04 (for Toshiba AC100), there is such an option in the settings, exactly as shown in the image in https://askubuntu.com/a/85069/19753 .

Perhaps, the required component of the settings menu isn't installed in your system. What can be the explanation otherwise?

Perhaps, that's the problem regarding "the ALPS touchpads which are not recognized by Ubuntu. They behave as a PS2 mouse and the touchpad tab is missing from the mouse menu. Therefore there is no scroll option and, the most annoying thing, while typing, the cursor often jumps because I touch the touchpad. I found a program which can disable the touchpad on command: touchpad-indicator, which was found on the Ubuntu help page. This program seems to be able to stop and start the touchpad on command."

I don't know whether you have such an ALPS touchpad. If so, touchpad-indicator could be of some use to you.


For KDE, set Touchpad settings → Tap Detection → Maximum Time to 0 ms. Verify by checking that the output of the command synclient contains MaxTapTime = 0.


I know this has been answered in the past, but I found for my 2017 xps, I needed to add a few additional settings to actually disable it. I think made the more modern synaptics drivers use these settings instead.

synclient TapButton1=0
synclient TapButton2=0
synclient TapButton3=0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .