What is the command I ran and now I have no ubuntu left...

When I which the computer on, the monitor comes on, it goes passed the grub screen, it does not show anything after that. How do I fix this?


3 Answers 3


I haven't tried this myself, but it may work. I don't really know what you mean by "I have no Ubuntu left" and how much of Ubuntu you are missing.

Take a look at https://help.ubuntu.com/community/Tasksel

The first thing i would try is to run...

sudo apt-get install ubuntu-desktop^

It may help. If not, let us know.

  • I had to login to recovery mode from grub, drop down to the command line with networking and ran tasksel and selected ubuntu-desktop. the desktop is back. However, I don't have the plymouth boot screen anymore. Nov 7, 2010 at 8:42

According to this bug report, tasksel behaves badly when removing packages. It seems that it removes many packages that it shouldn't, which can leave the machine in an inconsistent state.

Package Removal (A Better Way)

To remove something that you installed with tasksel, you need to mention the packages specifically. For example:

sudo aptitude remove apache2 apache2.2-common php5-common mysql-common

The theory is that removing these packages will cause the other parts of each system to also be removed. However, a manual search through Synaptic would still be beneficial.

This answer gives a much more detailed listing of what needs to be removed if you're trying to remove the LAMP stack.


To recover from tasksel's over-zealous removals, you have to reinstall the affected packages. In some cases, installing ubuntu-desktop will do the trick:

sudo aptitude install ubuntu-desktop

To be more thorough, open up the Ubuntu Software Center and look through your removal history (see screenshot) to find the packages that were removed at the same time that you ran tasksel remove. You can then reinstall those packages.


This is a common bug with ubuntu (see #574287).

I was recently faced with the same issue. To address this, Once I was faced with the blank screen, I accessed an Auxiliary terminal by pressing Ctrl+Alt+F1 (F1-F6) usually work for me, logged in and ran sudo tasksel again to recover from my mistake.

Not the answer you're looking for? Browse other questions tagged or ask your own question.