1

I have steam client installed on my SSD. And I have games installed on secondary HD. When I go to Settings and Add Library Folder I navigate to /media/user/Storage/Programs/steamapps and select. It gives the error

New Steamlibrary folder must be on a filesystem mounted with execute permissions.

So I tried to unmount my drive and remount it. Same error. Then I right clicked the folder and checked that the permissions were set to Create and delete files. Same error. The file system is showing Owner:Me.

I am running Ubuntu 19.10.

  • So I tried to mount via terminal instead of just through the ubuntu files app. And this is what I got: '$ sudo mount /dev/sdc1 /media/storagehd [sudo] password for user: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Falling back to read-only mount because the NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting.) Could not mount read-write, trying read-only' So seeing this I might need to reformat that HD which sucks because all of the steam games are on it. – Kehlan Nov 15 '19 at 16:08
  • I have a 3rd HD that Windows is on. So it shouldn't have any files on this HD at all. I don't get it. – Kehlan Nov 15 '19 at 16:09
0

This is resolved. I had to disable Windows Fast Start inside of Win10 because I didn't have the option in my bios (mobo: AsRock Extreme4 Z77). Once I did that then I did a shut down in Windows and booted Ubuntu. I ran the same command and added the library successfully.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.