1

I have an oldie laptop (P4-1.6/512 MB) with this video adapter S3 SuperSavage IX/C 16 MB. With Windows XP, it's even capable of playing 720p. However, I'd like to switch this thing to Linux. So, I did booted it from an HDD with Lubuntu 16.04 (and tried with 18.04, too). And the thing is, it struggles even with 480p, not to mention 576p or 720p (both mpv or VLC).

Here's some info:

~> sudo lshw -c video
*-display UNCLAIMED
    description: VGA compatible controller
    product: SuperSavage IX/C SDR
    vendor: S3 Graphics Ltd.
    physical id: 0
    bus info: pci@0000:01:00.0
    version: 05
    width: 32 bits
    clock: 66MHz
    capabilities: pm agp agp-2.0 vga_controller bus_master cap_list
    configuration: latency=248 maxlatency=255 mingnt=4
    resources: memory:ffe80000-ffefffff memory:dc000000-dfffffff memory:d8000000-dbffffff memory:d6000000-d7ffffff memory:c0000-dffff

And this one, too:

~> glxinfo | grep -i opengl
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

With mpv, I tried specifing various --vo= options, together with --hwaccel=auto, but it just fails with everything except --vo=x11 and sees no hardware acceleration. However, as I understand, it does use the hardware acceleration in Windows, since it does play 720p with no problems at all (with MPC and LAV Splitter).

So, the question is simple, what can be done? :) Any specific drvers may be? Some workarounds with players? Anytihng to improve the performance...

Thanks.

EDIT: I also forgot to mention I actually tried installing xserver-xorg-video-savage driver. Unfortunately, while installing, it uninstalled some (a lot, actaully) of other X related packages and nearly killed my system (after restart, I was unable to start X). That was my attempt with 18.0.4 mentioned above :). I have to re-installe the system and went with 16.0.4 this time (this laptop doesn't have too much memory :).

EDIT 2: Now, I see there seems to be some other Savage related options:

~> sudo apt search savage

[...]

xserver-xorg-video-savage/xenial 1:2.3.8-1ubuntu3 i386
X.Org X server -- Savage display driver

xserver-xorg-video-savage-hwe-16.04/xenial-updates 1:2.3.9-1ubuntu1~16.04.1 i386
X.Org X server -- Savage display driver

xserver-xorg-video-savage-lts-utopic/xenial-updates 3:13 i386
Transitional package for xserver-xorg-video-savage-lts-utopic

xserver-xorg-video-savage-lts-vivid/xenial-updates 3:13 i386
Transitional package for xserver-xorg-video-savage-lts-vivid

xserver-xorg-video-savage-lts-wily/xenial-updates 3:13 i386
Transitional package for xserver-xorg-video-savage-lts-wily

xserver-xorg-video-savage-lts-xenial/xenial-updates 3:13 i386
Transitional package for xserver-xorg-video-savage-lts-xenial

Should I try these instead?

Also, there are't any proprietary drivers, right? If there were any, i would see those in Additional Drivers?

EDIT 3: Installing xserver-xorg-video-savage-hwe-16.04 results in the system failing to start GUI, and if I ssh into that machine, glxinfo | grep -i opengl doesn't produce any output. So, I rolled back on that. Any suggestions? :)

  • 1
    You may need to install xserver-xorg-video-savage-hwe-16.04, if the Hardware Enablement Stack is installed. Check with dpkg -l | grep hwe. – mikewhatever Nov 14 at 17:14
  • @mikewhatever, I can't try that right now but thanks. – A S Nov 14 at 17:15
  • @mikewhatever, dpkg -l | grep hwe results are here (the HDD is taken from another laptop, that's why it has those ATI entries :). So, what should I try? – A S Nov 14 at 17:52
  • @mikewhatever, OK, I tried xserver-xorg-video-savage-hwe-16.04 :). After that, the system fails to boot into GUI and glxinfo | grep -i opengl fails to output anything. Luckily, it was possible to roll back this time :) What would you say? – A S Nov 14 at 18:21
  • 1
    Not sure really. The driver is, apparently, correct. Let's wait and see if others know more. – mikewhatever Nov 14 at 19:57
0

The driver seems to be in the repositories, so try to install it, and reboot.

sudo apt install xserver-xorg-video-savage-hwe-16.04

I don't know if it's going to work, the hardware is so old, it will be no surprise if the support is flaky. ...and even if it does, it will not play youtube videos well. Consider that none of the currently used by youtube codecs existed 20 years ago, not to mention having just 512MB of RAM in 2019 is not ideal.

  • 1
    Yeah, forgot to mention, I tried it. And while installing, it uninstalled just about everything else related to X and simply killed my install :) (that was my attempt with 18.0.4 mentioned in the post, had to re-install everything, so installed 16.0.4) – A S Nov 14 at 16:21
  • 1
    @A S Please put these findings in your questions! Very important to let others know what's going on, and Comments are transient. Please click on askubuntu.com/posts/1188774/edit and add what you found. – K7AAY Nov 14 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.