1

I installed Ubuntu 18.04 and find in very inconvenient: Alt-Tab (switch between applications) can bring you to a different desktop.

Usually I keep windows related to different activities on different desktops, e.g. the git desktop (some terminal windows and a text editor, sometimes gitk), the remote server desktop (two terminals with ssh, Firefox with a page from that server, and a text editor), the corporative mail desktop (Firefox with e-mail web interface, Skype, one more text editor), the source code desktop (IDE, some terminal shells and a text editor), etc.

In other words, Terminal and Gedit have many windows on different desktops, and these windows are unrelated, so grouping windows by application does not work.

How do I switch between windows on the current workspace?

0

1 Answer 1

1

Install Tweaks and shell extensions by running

sudo apt install gnome-tweaks gnome-shell-extensions

Then open Tweaks and go to Extensions: enable Alternatetab, customize it: tick Show only windows in the current workspace.

5
  • Without installing anything, you could also run: gsettings set org.gnome.shell.window-switcher current-workspace-only true Commented Nov 14, 2019 at 10:02
  • @jacob But that won't disable the 'grouping windows by application' feature, which is something OP doesn't want either (OP wants to switch windows). So for that reason this answer looks more useful to this specific question.
    – pomsky
    Commented Nov 14, 2019 at 10:45
  • @pomsky what gnome-tweaks does is exactly change the gsettings value I mentioned. Try running dconf watch / and make the change in gnome-tweaks. Commented Nov 14, 2019 at 10:51
  • @jacob I think you have overlooked the "installing gnome-shell-extensions and enabling Alternatetab" part from the answer. Seems like OP wants both the following: switching between windows (as opposed to grouped-windows of the same application) and isolating workspaces. The gsettings command achieves the second part, whereas this answer deals with both in one go.
    – pomsky
    Commented Nov 14, 2019 at 11:14
  • @pomsky ah, wait, you're right. skimmed gnome-tweaks, missed the rest of the line. Commented Nov 14, 2019 at 11:47

Not the answer you're looking for? Browse other questions tagged .