1

Whenever my system tries to update itself after upgrading from 19.04 to 19.10, it fails. I'm not sure what or where the problem is so what should I do to get it to update?

Screen capture of error message.

Running sudo apt-get update && sudo do-release-upgrade gives several lines of output including this error:

Error: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit -.mount is masked.
3
  • Try sudo apt-get update && sudo do-release-upgrade, you'll get plenty of useful output— copy them here if there's any error. – Liso Nov 14 '19 at 3:49
  • @Jim Thank you, error output posted! – DonP Nov 14 '19 at 4:37
  • So what does Error: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit -.mount is masked. mean and how do I get rid of it? I'm getting it on two of my systems after upgrading from 19.04 to 19.10. – DonP Nov 15 '19 at 1:03
0

Try unmasking this unit like this:

sudo systemctl unmask mount
1
  • Thank you. On one system, it gives Unit mount.service does not exist, proceeding anyway but the other system is unavailable right now so I'll give it a try there once it is back online after a remodel. – DonP Dec 7 '19 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.