0

After installing a fresh 18.04.3 server, the server is receiving "the next free" IP address, even if it is reserved a static IP on the DHCP server.

After some research, what I've already done is edit /etc/dhcp/dhclient.conf and removed all parameters from the request command. I've read the default should be fine.

After renewing with the commands sudo dhclient -r and sudo dhclient enp3s0 i am receiving the correct IP.

However, after a reboot, it receives the old IP again (the next free lease, not the static correct one).

sudo dhclient -r and sudo dhclient enp3s0 again makes sure I get the static one.

How can this be fixed permanently, across reboots?

  • Edit your question and show me cat /etc/netplan/*.yaml and cat /etc/network/interfaces. – heynnema Nov 13 '19 at 21:33
  • You should set the static IP in your router settings to prevent this from happening. – mchid Nov 13 '19 at 23:09
  • Solution found, see link below. Thanks for the help. superuser.com/questions/1338510/… – fritz Nov 14 '19 at 9:12
  • 1
    @fritz Please post what you did as an answer. You can add the link of the above question as source. – Kulfy Nov 14 '19 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.