1

A recent change is that running gnome-terminal (the "Terminal" application) from the launcher now finds an existing window if one is open. In 18.04, doing this would always open a new terminal window.

This is really annoying. I typically have half a dozen workspaces open for different things, and when I try to launch a terminal, I want a new one on the workspace I'm on, not to be dragged to a different workspace that happens to have a terminal already open where I then have to create a new terminal window and drag it back to the workspace where I want it.

Is there some way to change back to the old behaviour?

  • 1
    are you on 19.10 0r 18.04? – PRATAP Nov 13 '19 at 10:50
  • The behavior you describe is not the result of any change, it's the expected behavior and has been for quite some time. (unity and gnome-shell). There is a desktop action on right click on launcher icon that open a new window/terminal. – doug Nov 13 '19 at 15:43
  • I'm pretty sure that all my installs pre 19.10 defaulted to launching a new terminal. I'd hit the windows/super key, type 'term' hit return and a new terminal window would appear. Now it's just finding the one that I didn't want to be typing in. Reminds me of the horrible behaviour that MS introduced in Windows 8 which did much the same thing. – Ceisc Dec 18 '19 at 18:29
3

Use the Middle-Button on your mouse when you're clicking on the icon. This will open a new instance of that application in gnome.

But I suggest you to make a shortcut for yourself for Terminal because you're going to put your hands on the keyboard anyway. I use Super + Enter since I use terminal too much!

You can also change the /usr/share/applications/org.gnome.Terminal.desktop and change the gnome-terminal exec commands to gnome-terminal --window.

| improve this answer | |
  • 1
    It is also possible to use Gnome Tweaks for setting that clicking an item on the Dash by default launches a new instance rather than switching to an existing instance. Would be good to add that possibility to your answer. – vanadium Nov 13 '19 at 13:27
  • I didn't know you could set a keyboard shortcut for a terminal - good idea. – Tom Nov 13 '19 at 16:27
  • Couldn't find anything in tweaks which seemed to do what I needed, but adding --window has done the trick nicely :) – Ceisc Dec 18 '19 at 18:46
  • Just as an update, adding --window did not fix it. The suggestions of using the middle mouse button is useless to me as the entire point of me bringing up the launcher with a keyboard button press and typing stuff is that specifically do not want to touch the mouse. – Ceisc Mar 15 at 19:41
1

If you are using Gnome... Go to "Extensions". Look down the list for "Launch new instance". Set it to "ON". This affects more than the gnome-terminal window but I also find the behaviour of returning to the same terminal window extremely annoying. An alternative is to hit the context menu button in the currently open terminal window and hit "T" (or just "ENTER" because it is already on the "Open terminal" menu item at the top of the context menu) for a new terminal window, then do a "ctrl-alt-shift-downcursor" to move the new terminal window into the next available desktop. I frequently do this when opening multiple terminals already set to the directory I am working in. Saves all the cd'ing you might otherwise do. If you are using the mouse to do things, it will only slow you down. I strongly recommend learning your way around keyboard methods of doing things. Makes things quicker.

| improve this answer | |
  • Where these Extensions could be found? Do you mean additional GUI tool, that should be downloaded? Then offer a command to install it. – Gryu Feb 28 at 11:00
  • That seems to be exactly what I needed. – Ceisc Mar 15 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.