0

This message prompted. Although I configure/make libxerces-c3.2 separately.

ehan@rehan-Y11C:~$ sudo apt install build-essential autoconf automake libvmu-dev libfox-1.6-dev libproj-dev libxerces-c-dev libxerces-c3.2 libgdal-dev default-jdk 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libvmu-dev
E: Unable to locate package libxerces-c3.2
E: Couldn't find any package by glob 'libxerces-c3.2'
E: Couldn't find any package by regex 'libxerces-c3.2'
  • You haven't mentioned your release, but libvmu-dev isn't a Ubuntu repository library? packages.ubuntu.com/… Why are you adding it? (if there are instructions you are following, providing more detail may help, I don't know SUMO-0.32) – guiverc Nov 13 at 7:49
  • Sir actually i am trying to install sumo-0.32 with ns-3.27 on ubuntu-18.04.1 os. It is being mentioned in instruction before configuration you have to installed these packages, build-essential autoconf automake libvmu-dev libfox-1.6-dev libproj-dev libxerces-c-dev libxerces-c3.2 libgdal-dev default-jdk Reading package lists. but when in try to install it results an error mentioned above – Rehan Tariq Nov 13 at 8:11
  • rehan@rehan-Y11C:~$ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=16.04 DISTRIB_CODENAME=xenial DISTRIB_DESCRIPTION="Ubuntu 16.04.6 LTS" – Rehan Tariq Nov 13 at 8:38
  • If you look at my prior link - the package you are trying to add does not exist; so the message "Unable to locate package libvmu-dev" is correct (why I provided the link, and asked why you were adding it? as I'd check your instructions - it doesn't exist for any supported release of Ubuntu). Add additional information to your question (you can edit your own questions) though I'm not sure of your release as you've now provided two. – guiverc Nov 13 at 11:45
  • Please post your question only once and do not make multiple copies of the same question. – Thomas Ward Nov 13 at 16:26
0

Hmm, it seems you are running Ubuntu 16.04.

libxerces-c3.2 is not available in Ubuntu 16.04.

So, you have to resort to libxerces-c3.1:

sudo apt install build-essential autoconf automake libxmu-dev libfox-1.6-dev libproj-dev libxerces-c-dev libxerces-c3.1 libgdal-dev default-jdk 

or manually download libxerces-c3.2 (may break some dependant packages):

wget http://mirrors.kernel.org/ubuntu/pool/universe/x/xerces-c/libxerces-c3.2_3.2.0+debian-2_amd64.deb
dpkg -i libxerces-c3.2_3.2.0+debian-2_amd64.deb
sudo apt install build-essential autoconf automake libxmu-dev libfox-1.6-dev libproj-dev libxerces-c-dev libgdal-dev default-jdk 

By the way, I think you confused libxmu-dev thinking libvmu-dev.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.