Recently, I installed the latest version of the salome-meca software, obtained from here:


After installed it, I try to run it going into the folder ~/salome_meca/appli_V2019_univ and executing ./salome but I got the following error:

pablo@pablo-H110M-A:~/salome_meca/appli_V2019_univ$ ./salome
runSalome running on pablo-H110M-A
Searching for a free port for naming service: 2813 - OK
Searching Naming Service  + found in 0.1 seconds 
SALOME_Session_Server: error while loading shared libraries: libQt5Help.so.5: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/home/pablo/salome_meca/V2019_univ/modules/KERNEL_V9_3_0/bin/salome/orbmodule.py", line 172, in waitNSPID
ProcessLookupError: [Errno 3] No such process

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/pablo/salome_meca/appli_V2019_univ/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/pablo/salome_meca/appli_V2019_univ/bin/salome/runSalome.py", line 578, in startSalome
  File "/home/pablo/salome_meca/V2019_univ/modules/KERNEL_V9_3_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError("Process %d for %s not found" % (thePID,theName))
RuntimeError: Process 18072 for /Kernel/Session not found
Searching /Kernel/Session in Naming Service  

--- Error during Salome launch ---

I think that I have a problem with Qt5 library, but before doing anything I prefer to ask how to solve it.

1 Answer 1


The initial error occurred because libQt5Help.so.5 was not found. The libqt5help5 package provides this file. I had hoped installing that package may be sufficient to solve the problem, and for some readers of this post, it might:

sudo apt install libqt5help5

However, sometimes the specific package you're looking for is one of many packages you need, and is often installed as a dependency of something that provides more general functionality. Running apt rdepends package sometimes helps in figuring this out. The output of apt rdepends libqt5help5 shows python-pyqt5 and python3-pyqt5. Since the error messages you're getting are from Python, and this software appears to be from 2019, I would proceed by installing python3-pyqt5 instead:

sudo apt install python3-pyqt5

I was mistaken in my previous belief that Salome-Meca used Python 2. My apologies!

I have not found specific advice in the documentation for Salome-Meca. So that is a reasonable place to start. On my system, I was able to overcome error messages about missing libraries using:

sudo apt install qtcreator net-tools libqt5opengl5 libnlopt0

Installing qtcreator is a kitchen-sink approach to getting Qt libraries. It installs way more than is likely to be necessary--about a gigabyte on my system--and if I find a better way to install what is needed, I'll try to update this with that information.

After I did that, it still wouldn't start. I got errors like those shown here, of the form:

SALOME_Session_Server: /home/ek/salome_meca/V2019_univ/prerequisites/debianForSalome/lib/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /lib/x86_64-linux-gnu/libGLU.so.1)
SALOME_Session_Server: /home/ek/salome_meca/V2019_univ/prerequisites/debianForSalome/lib/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /lib/x86_64-linux-gnu/libQt5Xml.so.5)
SALOME_Session_Server: /home/ek/salome_meca/V2019_univ/prerequisites/debianForSalome/lib/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /lib/x86_64-linux-gnu/libQt5OpenGL.so.5)

...and so on.

I was able to solve (or, in any case, work around) that problem by making Salome-Meca use my system-provided version of libstdc++.so.6 rather than the version it ships. I did this with LD_PRELOAD:

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libstdc++.so.6 ./salome

When I run Salome Meca that way, it starts successfully:

screenshot of the Salome-Meca graphical interface

I suspect that your errors about not having correct library versions available may be solvable by installing qtcreator, using LD_PRELOAD to specify your libstdc++.so.6, or both. (I'm not really sure quite what those errors said, though, and I recommend you update your question with them, whether or not this works.)

Note that if you use LD_PRELOAD but you're not running a PC or Mac with a 64-bit Intel or AMD processor, then the path you write after = will be different from mine. For example, if you're using a 32-bit system, or an ARM system (of any word size), then your architecture isn't amd64. You can search for libstdc++.so.6 to find the appropriate path.

  • @PabloBascuñan I've managed to download Salome-Meca from the official site (I'd been having trouble with this initially) and I'm working on trying to get it to work. I've found it actually uses Python 2 rather than Python 3. Does installing the python-pyqt5 package help, or otherwise change the error messages? Commented Nov 13, 2019 at 0:02
  • I tried installing python-pyqt5 but the error output is too long to show you here. This is an extraction of the error: Searching /Kernel/Session in Naming Service +SALOME_Session_Server: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version Qt_5' not found (required by SALOME_Session_Server) SALOME_Session_Server: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.9' not found (required by SALOME_Session_Server) SALOME_Session_Server: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by SALOME_Session_Server) Commented Nov 13, 2019 at 0:08
  • @PabloBascuñan Do you get that output when you install python-pyqt5, or after installing it when you run ./salome? (Unfortunately, the only machine I have available to test this on right now is slow and has no GUI installed, so it's actually missing quite a bit of things that you're unlikely to be missing.) Commented Nov 13, 2019 at 0:11
  • It happens after I tried to run ./salome. Commented Nov 13, 2019 at 0:13
  • @PabloBascuñan Is the libqt5core5a package installed? Commented Nov 13, 2019 at 0:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .