I have Ubuntu Studio 19.04 installed recently. I am trying to revive my installation of vim. I installed it thru apt-get, and and have installed Vundle. The problem is now, I have no useable plugins. It appears to crap out on the :PluginSearch colon command, so that Vundle can't list or install plugins. Below are the messages that was flashed on my instance of vim when I tried PluginSearch. I managed to catch "flashed" error message on video and took a screenshot of a frame from the video.

A split second after that message, I was returned to a split window, which had an empty plugin list, but below it said "1 plugins found".

I tried to go online to see how to solve this, but no one had quite this error, and no provided solution resulting in overcoming the plugin installation problem, after hours trying them.

If anyone can offer suggestions, such as what parts of Vundle these errors are coming from, and possible workarounds, I would appreciate it.

Flashed error messages follow:
Error detected while processing function vundle#scripts#all[3]..<SNR>31_load_scripts:
Line 7:
E15: Invalid exression: <html>^M
E15: Invalid exression: <html>^M
Error detected while processing function vundle#scripts#all:
Line 10:
E686: Argument of reverse() must be a list
Error detected  while processing function vundle#scripts#all[10]..vundle#scripts#view:
Line 1:
E712: Argument of map() must be a list or Dictionary
Error detected  while processing function vundle#scripts#all[10]..vundle#scripts#view:
Line 15:
E745: Using a List as a Number
E116: Invalid arguments for function append

Paul King

  • 1
    It appears you might not have set it up properly. Try installing afresh. Nov 12, 2019 at 4:43
  • @GeorgeUdosen What is "afresh"?
    – jumpnett
    Nov 15, 2019 at 19:32
  • 1
    @jumpnett what I mean is, you should install it again starting from the beginning! Nov 16, 2019 at 6:27
  • I thought "afresh" was an app, lol
    – jumpnett
    Nov 18, 2019 at 17:42

1 Answer 1


The problem here is that apparently Vundle is a legacy package manager for vim, and when we use the PluginSearch function, it downloads available scripts lists from vim-scripts.org. A visit to the said address reveals that the website has been discontinued:

This used to be a mirror of Vim's scripts site on Github.

It was created to allow early package managers (such as Vim Update Bundles and Vundle) to install scripts straight from GitHub *.

Now that most Vim scripts are developed on GitHub and installable straight from the source, I'm happy to say that there's no need for vim-scripts anymore.

Available scripts can now be found on https://www.vim.org/scripts/, and to install, just add Plugin 'your-required-plugin' in your .vimrc file somewhere filetype off and filetype plugin indent on.

Walkthrough In your terminal instance, type vim ~/.vimrc. This will open the file if it exists, or create a new one if you save the changes. The following is what I have in my .vimrc, you can simply copy and paste it, and install the plugins of your choice below this comment: " add all your plugins here (note older versions of Vundle used Bundle instead of Plugin)

syntax enable
set tabstop=4
set expandtab
set autoindent

set nocompatible        " required
filetype off            " required

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#rc()

" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/vimPlugins/')

" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'

" add all your plugins here (note older versions of Vundle used Bundle instead of Plugin)
Plugin 'python-mode/python-mode'
Plugin 'Royal-Colorschemes'
Plugin 'tmhedberg/SimpylFold'
Plugin 'vim-scripts/indentpython.vim'

" ...

" All of your Plugins must be added before the following line
call vundle#end()       " required
filetype plugin indent on   " required
  • Thanks for your reply!
    – Paul King
    Jul 9, 2021 at 1:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.