2

I want to change the TrackPoint driver from libinput to Synaptics. I am using a ThinkPad X390 and I have tried the latest version of the libinput driver and I have tried to find out why the libinput driver is behaving in a way that makes the TrackPoint unpleasant for me and I now want to change back to Synaptics until libinput is developed further. I have verified that the TrackPoint seems to be running well on 16.04, which features the Synaptics driver.

How might this switch be done from libinput to Synaptics on Ubuntu 18.04 LTS?

I have already run the following:

sudo apt install xserver-xorg-input-synaptics-hwe-18.04 xserver-xorg-input-evdev-hwe-18.04
sudo apt remove xserver-xorg-input-libinput-hwe-18.04
1
sudo apt install xserver-xorg-input-synaptics-hwe-18.04
sudo apt install xserver-xorg-input-evdev-hwe-18.04
sudo apt remove xserver-xorg-input-libinput
sudo apt remove xserver-xorg-input-libinput-hwe-18.04

Whether libinput or Synaptics is in use can be ascertained by getting the device name from the output of xinput --list and then listing the properties of the device using a command like the following:

xinput --list-props "TPPS/2 Elan TrackPoint"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.