5

I'm using Kubuntu and I can't for the life of me find how I can stop the Alt key from toggling my menu on each window. It's the feature that lets your search your menus with your keyboard, highlighting the first letter of each entry. Image below.

enter image description here

Does anyone know where this is set? Nothing in my global shortcuts or my normal shortcuts seems to be bound to Alt and nothing with the word "menu" in it looks relevant.

6
  • 1
    Other than Firefox, which other applications in Kubuntu show this problem? Do you press only the Alt key and then release it? And is this intentional or accidental? There maybe some application-specific fixes.
    – DK Bose
    Nov 12, 2019 at 1:50
  • And is this still the same keyboard?
    – DK Bose
    Nov 12, 2019 at 11:25
  • 2
    Nice detective work! No this happens on all of my installs on multiple applications. Vscode is the other one that comes to mind as especially annoying. It isn’t intentional. I just have keybinds that use alt and sometimes I back out of an action after just pressing alt when I would have held it. Nov 12, 2019 at 17:15
  • 1
    In Kubuntu 18.04, pressing Alt alone does nothing and doesn't open a menu with Dolphin, Gwenview, Kate, and Konsole (qt apps) and Geany, Gedit, Google Chrome, LibreOffice, and Mousepad (non-qt apps). I don't use "Vscode". So, for me, Firefox is the only app that opens its menu bar, not the dropdown itself (because I've set the Firefox menu bar to be hidden by default.
    – DK Bose
    Nov 12, 2019 at 18:04
  • 2
    Yeah it steals focus on apps that hide their menu bars, but if you hold it you should be able to see that the first letter of each menu item becomes underlined. I hide my menus on firefox and vscode so its the worst there. Nov 12, 2019 at 21:33

1 Answer 1

2

This is the Common User Access menu IBM developed decades ago, which dates back before MS-DOS, and is a standard on many, many operating systems.

Switch Alt and Meta keys in Keyboard settings, then Change all Alt+... keyboard shortcuts to Meta+... ones and vice versa; rather tedious, but works. Thanks to lashkevi for the tip.

4
  • 2
    Thanks you, I have no idea how I would have found that otherwise. Before I do all that work, no one knows of a way to just disable this entirely? IIRC, Ubuntu didn't have this in the gnome 2 days. Nov 11, 2019 at 18:10
  • 2
    Will do. Holding out now for an answer that doesn't require that I update all of my keybinds to use meta instead of alt. Nov 11, 2019 at 19:28
  • 1
    I would, too. Mine is the least worst answer.
    – K7AAY
    Nov 11, 2019 at 19:35
  • 1
    This might be a Qt thing... not sure that it's part of Kubuntu/KDE bugreports.qt.io/browse/QTBUG-45687. Also see this thread forum.kde.org/viewtopic.php?f=111&t=119019
    – ATOMP
    Dec 30, 2021 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.