2

I installed Darktable in the past through Ubuntu Software Center and it worked perfectly. However, in the Darktable preferences tab, OpenCL was not enabled.

I really want to have OpenCl enabled as it boosts Darktable's performance. Thus I made sure I had the correct NVIDIA driver that allows OpenCL configuration enabled and tried running darkatbe-cltest, which failed and showed this error message:

darktable-cltest not known 
You can install it with sudo apt install darktable

I was a bit confused, because I already had Darktable installed as described above.

But I did proceed with sudo apt install darktable, which installed a new version of Darktable on my computer.

I also used sudo add-apt-repository ppa:pmjdebruijn/darktable-release, in order to update to the newer version. Oddly, this new version now supports OpenCL!

Now I have 2 different versions of Darktable on my computer, both version 2.6.2. However, one supports OpenCL, while the other does not. Also the layout of the two versions is slightly different (different font size and padding).

When I run Synaptic, I can only see one version of Darktable, the one installed from the terminal.

And when I try to find packages installed through Ubuntu Software Center, like Discord, I can't find them in Synaptic.

Because I thought Ubuntu Software Center was a GUI of the terminal, it is a bit strange not to find every package installed in Ubuntu Software Center.

(NB: I have to mention that I did run sudo apt-get update && sudo apt upgrade a few times and also updated through Synaptic some of the packages I saw there.)

  • 1
    You've installed the darktable snap from Ubuntu Software, which is why you can't find it from apt nor synaptic. You can have both a snap and deb installed which are the same version, and they may be compiled differently (or not be able to use certain features due to confinement of snaps). – dobey Nov 11 at 15:53
  • thanks @dobey , is it a feature of the Software Center to provide snaps instead of deb ? If i am right snaps are snapshots of a specific package then not really updatable across time ? Also my snap of Darktable 2.6.2 does not provide same look or even featurs as deb 2.6.2 of Darktable.. Is it something that happens often ? – Maxence Nov 11 at 15:56
  • 2
    Yes, Ubuntu Software includes both debs and snap packages. No, snaps are not "snapshot" packages. They are a different packaging format from normal debian packages. The look is probably different because of confinement and so it's not getting the theme properly. I don't know if OpenCL difference is a confinement or compilation issue. But snap packages work differently than you are used to with debs. – dobey Nov 11 at 16:03
  • Thank you. I now realize I can see both versions. Thought they were kinda duplicates, but one shows source: Snap Store and the other lp_ppa_pmjdebruijn_darktable_release-bionic-main . I have just read about snap vs deb but this is too technical for me at this time (but will read about it more in the future). The snap looks better and despite it doesnt offer support for OpenCL I think I will keep it. Thanks for your precisions. – Maxence Nov 11 at 16:09
2

Debian and Ubuntu apt-get, apt, synaptic (and maybe a bunch of others) provides software packages from repositories in the "old fashioned" way of using deb files (similar to redhat rpm files which has been around for long). These are easy to use, but installs software and libraries in the "old fashioned" way of adding them to the host operating system; which may break the entire OS if a bad mismatch occurs.

Snap and the similar AppImage and Flatpak are other ways to install software, they differ in the way that the software ends up in a "container", with the feature that the container includes ALL software that is required to run the package (and thus "CANNOT" disturb the host OS). But this comes with the caveat that the container might need special settings - at least - to communicate with (or maybe use portions of) the actually installed operating system or hardware and it's files and/or libraries.

E.g., to have a gimp snap package be able to print using CUPS provided by the host OS, a single

sudo snap connect gimp:cups-control  

is required.

If you do not provide that, or if there is no such adaptation the OS feature will not be available.

I suspect this be the case with OpenCL in your situation.

Related: What are the differences between snaps, appimage, flatpak and others?

  • Thank you, though I don't know how to fix this. Yet I have compared performance of the deb and the snap and I can't really see any difference. Then I will stick to the Snap package which looks better (but is not openLC enabled) – Maxence Nov 11 at 17:07
  • The "fix" is; just remove one of them, using either of the apt or snap utilities. Whatever you stay with is a perfectly valid choice, all is up to you. – Hannu Nov 13 at 18:37
  • youtube.com/watch?v=lS1RLNqflUQ - intro to Docker, yet another "container" – Hannu Nov 23 at 22:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.