2

I can not install my printer on my Xubuntu.

At first, I had this problem (ie. I could find my printer, but got "internal server error" warnings when trying to install it), and as suggested I tried using the web interface at http://localhost:631

This does however not work, I can, as far as I can tell, install the printer, but it cannot print a test page (or anything else).

My procedure is as follows:

I go to http://localhost:631/admin and click add printer:

I click add printer

Then I select my printer among the presented options and in this case, and then I am presented with what appears to be a successful connection to the printer (as per the text in the field: connection, note that I have removed part of the address, which contains unique identification of my printer):

I have removed part of the address, which would uniquely identify my printer

It does not seem that pressing "share this printer" has any effect, I have tried both with this option on and off.

After this, I am asked to select a driver, I have both tried finding my printer in the drop-down menu (see below) or using a driver (.dpp file) provided by the manufacturer (which obviously is a Linux version):

Upload file, or select the selected

After this, I am asked for default options (these I don't consider relevant, so I won't show an image of that); finaly the installation should be done, and I go to the installed printer, try to print a test page, and nothing happens. After a while, a popup message appears telling me that the printer may be offline (it's not though), and the test page job itself simply claims that the state of the job is "unable to locate printer", see below:

Again, UUID has been removed

Interestingly, this is most likely not a Ubuntu problem, as I have tried to install this printer in the exact same way on a desktop running arch-Linux and even got someone to try on their FreeBSD laptop (no success either), but the printer can be used from Windows 10 (on the same laptop as my Xubuntu), and I can also get it to work on my old MacBook (which is strange, considering that it also should be running cubs)

1
  • It is working now, and I must admit, I don't know exactly why it is working now. My best bet is that it started working after an unrelated update of my router.
    – Nikolaj
    Sep 28, 2020 at 9:21

2 Answers 2

3

I had the same issue, and can confirm that ".local" is in the printer address, and this causes the problem.

I edited the printer configuration and removed .local and it all works. That is, my oringal printer URL was:

dnssd://Brother%20HL-L2395DW%20series._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c2af4879b9b

And I changed it to

`

dnssd://Brother%20HL-L2395DW%20series._ipp._tcp/?uuid=e3248000-80ce-11db-8000-3c2af4879b9b

I used KDE, so I:

  • "System Settings" => "Printers"
  • clicked on the printer
  • pressed the "Configure" button
  • edited the "Connection" url
  • Applied changes
  • Printed a test page.
1

I ran into the very same issue and using tcpdump and avahi-browse, I found the problem and came up with a simple fix.

The issue seems to be a bug with mdns lookups. For some reason when it looks for the printer, the hostname in the URL returnd by the mdns lookup and then passed to cups via port 631 has .local appended to it. I added an alias in the hosts files for <server_name>.local where <server_name> is the host with the attached printer and it all works fine now. This needs to be added to all of the hosts using the network printer.

This may just be an issue when the hostname returned by the cups server is not qualified with a domain name and makes one up called 'local', which I'll bet is the default domain name used by Apple products.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.