2

I am using Steinberg UR22mkII DAC (digital analog converter) for managing speakers. Steinberg is connected to computer via USB. This is my used SOUND OUTPUT in settings, so I can adjust volume at the top bar on a desktop.

I also have primary Samsung monitor on HDMI and projector on HDMI (but never use it for sound). All 3 devices (Steinberg on USB, Monitor on HDMI and Projector on HDMI are always connected to computer), but the projector is most of the time turned off.

In Settings/Sound/Output I have 4 options:

  • Digital output (S/PDIF) - Integrated sound
  • HDMI/Display port 6 - Hawaii HDMI Audio [Radeon R9 390]
  • Digital output (S/PDIF) - Steinberg UR22mkII
  • Analog output - Steinberg UR22mkII

I always use third option in settings, but after shutdown/reboot, selection changes automatically to the first one. So I have to choose third again. Every time since I upgraded to Ubuntu 19.10. On Ubuntu 18.04, there was no problem.

Thank you for help :)

  • Not an answer to your question but possibly a patch to your problem. Using PulseAudio you could set up a script on startup that changes the output. – Smurfz87 Nov 11 '19 at 11:05
  • My theory is this might happen if the device is not recognized as an audio output source early enough when your system is checking which sources is available and deciding which to use. Edit: quick search yielded similar assumptions – Smurfz87 Nov 11 '19 at 11:08
  • I tried PulseAudio to setup fallback for "Digital output (S/PDIF) - Steinberg UR22mkII", but after reboot, stil the same problem... I do not se options in PulseAudio to choose default audio device.... Just some lock and fallback icons.. – user908975 Nov 13 '19 at 12:20
  • the accepted answer here seems to be close to what you're after, only need to make it run on startup. Sink == audio output. – Smurfz87 Nov 13 '19 at 20:03
  • I would look at askubuntu.com/questions/1183052/… – John Manko Nov 17 '19 at 15:19
0

I've been having this issue on Ubuntu 20 myself and seen a couple ways of solving it.

In Startup Applications I've added an entry: pactl set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo where alsa_output.pci-0000_00_1f.3.analog-stereo is the device name for my analog stereo output (headphone port).

This is answered here slightly differently: How can I change the default audio device from command line?

I will add to this however by saying that not only does the default device rebooting on Ubuntu 20 still after every reset it can also not play on the correct device - even if the default is set after a reboot.

To get around this second issue as well you could use this answer rhttps://askubuntu.com/questions/78780/how-can-i-disable-an-audio-hdmi-device to disable all the HDMI audio sources. That would leave you with just the Steinberg device you were looking for - thus removing the need to set a default altogether.

I've used both and now sound is working well for me on Ubuntu 20.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy